AW: [Webtest] Problem with input element of type="image"

webtest@lists.canoo.com webtest@lists.canoo.com
Wed, 16 Oct 2002 09:03:41 +0200


Hi,

thanks for the pointers.

I'm convinced that it should work, although it doesn't for me.

I've only one form on my JSP, so there should not be a problem here.
Something strange is that the pictures are not found and replaced=20
by the standard placeholder in the result pages.=20

Our application is integrated in a Content Management System.
I suspect that there is some interferences between the CMS and Webtest.
I noticed as well that the request headers are not the same if I run =
the=20
application form a browser or using webtest.=20
So I guess that I'll have to solve this first!

Many thanks for your help.
Robert


> -----Urspr=FCngliche Nachricht-----
> Von: Dierk Koenig [mailto:dierk.koenig@canoo.com]
> Gesendet: Dienstag, 15. Oktober 2002 15:02
> An: webtest@lists.canoo.com
> Betreff: RE: [Webtest] Problem with input element of type=3D"image"
>=20
>=20
> Hi,
>=20
> your code should work like provided.
>=20
> Canoo WebTest fills the name.x and name.y values with 0.
>=20
> The Report of the automated tests that Canoo WebTest uses
> to test itself show this.
> - go to=20
> http://webtest.canoo.com/selftest/TestResultOverview.html#testspec13
>   This is the result page of the tests of the latest build.
>   You will find some clickbutton steps for ImageButtons.
> - select one of the "Resulting page" links with the green background
>   (e.g.=20
> http://webtest.canoo.com/selftest/lastResponse1032513277993.html)
>   to see the page that was returned. You will find the .x and=20
> .y values
>   listed at the bottom.
>=20
> You can use this as an example of the clickbutton with image buttons.
> Try to find out where your code differs from the example.
>=20
> Please tell us about your findings.
>=20
> cheers Mittie
>=20
> P.S. just as an idea: are you sure that the right form was submitted?
>=20
> > -----Original Message-----
> > From: webtest-admin@lists.canoo.com
> > [mailto:webtest-admin@lists.canoo.com]On Behalf Of
> > sem.Gottofrey@bkw-fmb.ch
> > Sent: Dienstag, 15. Oktober 2002 14:04
> > To: webtest@lists.canoo.com
> > Subject: [Webtest] Problem with input element of type=3D"image"
> >
> >
> > Hi all,
> >
> > Having following HTML code in my JSP,
> >
> > 	<input type=3D"image" name=3D"btn_open" =
src=3D"/images/btn_open.gif"
> > border=3D"0" alt=3D"open">
> >
> > I can submit my form with the following webtest element:
> >
> > 	<clickbutton stepid=3D"Click 'Open forecast'"  name=3D"btn_open" =
/>
> >
> > When the form get submitted, the two parameters 'btn_open.x' and
> > 'btn_open.y' should be
> > available on the request, but they are not.
> >
> > Am'I missing something?
> >
> > Thanks
> > Robert
> > _______________________________________________
> > WebTest mailing list
> > WebTest@lists.canoo.com
> > http://lists.canoo.com/mailman/listinfo/webtest
> >
>=20
> _______________________________________________
> WebTest mailing list
> WebTest@lists.canoo.com
> http://lists.canoo.com/mailman/listinfo/webtest
>=20