[Webtest] RE: Another error in Sample

Dierk Koenig webtest@lists.canoo.com
Mon, 30 Dec 2002 11:49:03 +0100


Hi Stephan,

thanx for your feedback.

> -----Original Message-----
> From: Stephan Wiesner [mailto:stephan@stephan-wiesner.de]
> Sent: Donnerstag, 26. Dezember 2002 7:59
> To: info@canoo.com
> Subject: Error in Canoo Samples
>
>
> Hi, there is an error in the first sample on your page:
> http://webtest.canoo.com/webtest/manual/samples.html
>
> It must be
>   <fileset dir="." includes="lib/*.jar"/>
> not
>   <fileset dir="." includes="/lib/*.jar"/>
>
> Otherwise the libraries will not be found.
> Stephan
---------------------------------------------------------

I acknowledge that in your environment it only works in
the first variant. For me, both variants work fine.

For troubleshooting you may want to find out where
"." actually points to, i.e. where your actual directory
is.

I appreciate any additional feedback on possible environment
settings that may cause the samples to fail.

---------------------------------------------------------
> Subject: Another error in Sample
>
>              <clickbutton
>               label="Login"
>               stepid="Click the submit button" />
> not
>              <clickbutton
>               stepid="Click the submit button" />
---------------------------------------------------------

Yes, as http://webtest.canoo.com/webtest/manual/syntax.html#7
states, "Either label or name is required".

Thanks for the hint.

---------------------------------------------------------
> The sample really is quite bad. Sorry to say that. It starts fine, but
> than is breaks comletely apart. The XML files mustn't contain
> <?xml version="1.0"?> ( using the latest build of Ant) and I could't
> generate your example.
---------------------------------------------------------

Sorry to hear that. Now, as we both are sorry - why do you say it in
the first place?

"quite bad" and "breaks completely apart" is not the kind feedback
that really helps our OpenSource effort to flourish.
You do not take into consideration that you may
be wrong or misunderstood something.
Nor do you offer to provide better examples or a text that is easier
to understand. To make things worse, your tone is outside the
acceptable range.

Well, to the details:

<?xml version="1.0"?>
Makes no problem for us, neither on in the developer environments nor
on the integration machine. On the other hand, it enables our XML-Editor
for Syntax Highlighting and Code Completion.
Have you possibly a different version of Xerces (or dependent libs)
on your classpath?

about building the samples:
look at http://webtest.canoo.com/webtest/manual/install.html#4
does that work?
if yes, start with the installTest.xml and apply the changes you need
if no, look at http://webtest.canoo.com/webtest/manual/troubleshooting.html

If it still fails, I recommend using the following tools:
http://www.inmansys.co.uk/tonic_products.html
http://www.sqa-test.com/toolkit.html
http://www.oclc.org/webart/
http://fit.c2.com/
http://www.google.de/search?q=testing+web+applications

---------------------------------------------------------
> Canoo really looks promising but without a working start documentation....
---------------------------------------------------------

... it is totally useless? A few thousand users were able to use it
even before any samples were provided.

Dierk