[Webtest] Strange behaviour with PHP???

Dierk Koenig webtest@lists.canoo.com
Mon, 9 Jun 2003 11:01:49 +0200


Hi Randall,

using the browser often means that you have a session where you may have
triggered your db call in one step, stored the results in the session and
use the results in later steps.
Canoo WebTest opens a session for every TestSpec. Therefore, cached results
may not be available unless you do the appropriate call within this
TestSpec.
Web applications very often rely on the availability of cached results in
the session although there are navigation paths through the webapp that do
not trigger the caching. This is a failure scenario that you can reveal
using Canoo WebTest and that you may have revealed unexpectedly.

BTW: this error scenario can be very hard to find with manual testing since
session restart can be quite some work for the manual tester ("exit - new
logon", "close all browser windows - make sure not invisible instances
exist - restart browser", or else)

cheers
Mittie



> -----Original Message-----
> From: webtest-admin@lists.canoo.com
> [mailto:webtest-admin@lists.canoo.com]On Behalf Of Randall Dietz
> Sent: Sonntag, 8. Juni 2003 6:56
> To: webtest@lists.canoo.com
> Subject: RE: [Webtest] Strange behaviour with PHP???
>
>
> Hmmmmm...  ok, it's not WebTest directly!  But the plot thickens...
>
> It appears that there's nothing coming back from the database
> when the page
> is invoked through WebTest (???).  But if I go to the same URL through the
> browser... it works fine!
>
> Can someone tell me more about how WebTest connects through HTTP
> and how it
> might differ to a browser?
>
> thanks -- Randall
>
>
> _______________________________________________
> WebTest mailing list
> WebTest@lists.canoo.com
> http://lists.canoo.com/mailman/listinfo/webtest
>