[Webtest] RE: get message about putting xalan.jar in ant/lib when it is

Dierk Koenig webtest@lists.canoo.com
Mon, 14 Jul 2003 10:02:21 +0200


Hi Lynn,

Your installation seems to be correct, as far as I can see it.

However, the error message indicates that some classes that are
typical or "representative" for Xalan and Xerces are not available.

As you have the proper files, but the classes are not found anyway,
finding the error is outside webtest. The intermediate goal is to make
any "style" or "xslt" task run.

Some problems that we encountered that led to similar errors where:
- broken jars. Try whether they unjar correctly.
- multiple ant installations and the "wrong" one is called
  accidentially. Check System properties (PATH, ANT_HOME), start
  ant in verbose mode.

hope that helps
Mittie

> -----Original Message-----
> From: webtest-admin@lists.canoo.com
> [mailto:webtest-admin@lists.canoo.com]On Behalf Of Lynn Walton
> Sent: Freitag, 11. Juli 2003 17:47
> To: webtest@lists.canoo.com
> Subject: [Webtest] RE: get message about putting xalan.jar in ant/lib
> when it is
> 
> 
> > What error message is at issue here?
> 
> Here is the relevant part of the verbose ant messages.
> I get BUILD SUCCESSFULL if I leave the  "unless=path.ok" part in  
> ApplyXSL.xml's
> failedIfBadPath target.
> But the summary html report isn't created.
> 
> I have the following in my ant lib directory
> 
> C:\Lang\ant\lib>dir
>  Volume in drive C has no label.
>  Volume Serial Number is 6C56-BF35
> 
>  Directory of C:\Lang\ant\lib
> 
> 04/16/2003  07:22p             737,884 ant.jar
> 04/16/2003  07:22p             671,546 optional.jar
> 04/16/2003  07:24p                 667 README
> 06/30/2003  12:02p           2,907,319 xalan.jar
> 06/30/2003  12:02p             895,924 xercesImpl.jar
> 04/16/2003  07:24p             885,250 xercesImpl.jar.cameWithAnt
> 04/16/2003  07:24p             108,484 xml-apis.jar
> 
> I tried renaming the xercesImpl.jsar that came with ant and 
> putting in the one that
> came with canoo's build 307 too.
> 
> report:
>      [copy] Copying 1 file to C:\Lang\canoo\myProjects\c2k\reports
>      [copy] Copying C:\Lang\canoo\myProjects\includes\report.css 
> to C:\Lang\cano
> o\myProjects\c2k\reports\report.css
> Project base dir set to: C:\Lang\canoo\myProjects\c2k
>       [ant] calling target applySingle in build file 
> C:\Lang\canoo\myProjects\in
> cludes\ApplyXSL.xml
> parsing buildfile C:\Lang\canoo\myProjects\includes\ApplyXSL.xml 
> with URI = file
> :C:/Lang/canoo/myProjects/includes/ApplyXSL.xml
> Project base dir set to: C:\Lang\canoo\myProjects\c2k
>  [property] Loading C:\Lang\canoo\server.properties
>  [property] Unable to find property file: C:\Lang\canoo\server.properties
> Override ignored for property resultfile
> Override ignored for property resultfile.html
> Build sequence for target `applySingle' is [onPath, 
> failIfBadPath, applySingle]
> Complete build sequence is [onPath, failIfBadPath, applySingle, 
> full, applyMulti
> ]
> 
> onPath:
>      [echo] true
> Override ignored for property path.ok
> 
> failIfBadPath:
> 
> BUILD FAILED
> file:C:/Lang/canoo/myProjects/includes/ApplyXSL.xml:28: Xalan 
> missing on classpa
> th. Put xalan.jar and xerces.jar to ant/lib.
> 
> Thanks,
> Lynn
> 
> _______________________________________________
> WebTest mailing list
> WebTest@lists.canoo.com
> http://lists.canoo.com/mailman/listinfo/webtest
>