[Webtest] (Fwd) Maven + Canoo + Linux : the right testing solution

Siegfried Göschl webtest@lists.canoo.com
Fri, 01 Aug 2003 11:58:28 +0200


------- Forwarded message follows -------
Date sent:      	Fri,  1 Aug 2003 11:36:59 +0200
From:           	anjarivo@free.fr
To:             	siegfried.goeschl@it20one.at
Subject:        	Maven + Canoo + Linux : the right testing solution 

Hi Siegfried,

Thank you for your 'patch'. This new version of "plugin.jelly" fixs
the problem:

webtest:info:
    [echo]
      maven.webtest.src                         = .
      maven.webtest.file                        = simpleTest.xml
      maven.webtest.target                      = main
      maven.webtest.src                         = .
      maven.webtest.config.host                 = actualite.free.fr
      maven.webtest.config.port                 = 80
      maven.webtest.config.protocol             = http
      maven.webtest.config.basepath             =
      maven.webtest.config.summary              = true
      maven.webtest.config.verbose              = true
      maven.webtest.config.saveresponse         = yes
      maven.webtest.config.resultpath           = target/webtest
      maven.webtest.config.resultfile           =
      maven.webtest.config.showhtmlparseroutput = true
      maven.webtest.config.haltonfailure        = false
      maven.webtest.config.haltonerror          = false
      maven.webtest.ant.options                 =


webtest:test:
    [echo] Starting Canoo Webtest ...
    [java] Buildfile: /home/anjarivo/Projects/MEW/simpleTest.xml
    [java]
    [java] main:
    [java]  [testSpec] Rhino classes (js.jar) not found - Javascript
    disabled [java] [java] BUILD SUCCESSFUL [java] Total time: 1
    second [echo] Finished running Canoo Webtest Plugin

webtest:generate-test-report:
    [copy] Copying 1 file 
to /home/anjarivo/Projects/MEW/target/docs/webtest/response
    [echo] Transforming TestSummary1-LoginPage.xml into XDOC ...

webtest:generate-summary-report:
    [echo] Summary
BUILD SUCCESSFUL
Total time:  5 seconds

It's cool, with this nice plug-in I'm able to run these tests using
Canoo and display them using Maven. The next step is to do 
"continuous
integration" maybe with "CruiseControl" :-).

Cheers

Anjarivo

PS : Please, can you send this e-mail to the mailing-list.

----------------------------------------------------------------------

--------- De : Siegfried Goschl [mailto:siegfried.goeschl@it20one.at]
Envoye : jeudi 31 juillet 2003 20:52 A : anjarivo@free.fr;
leandro@ibnetwork.com.br Objet : (Fwd) Re: Maven + Canoo : BUILD
FAILED Target `' does not exis


Hi,

I just patched the plugin.jelly - it is available as attachment and
from the CVS repo for maven-plugins.sourceforge.net. Basically I have
two different invocations of ANT depending on
maven.webtest.ant.options.

Could you give it a try and give me some feedback - I don't have a
LINUX box up and running. A similar problem could be the emtpy target
for the ANT goal to be executed ... if all works well please post a
success message ... :-)

I'm on holidays for the next week but can devote considerable time to
MAVEN for the following two weeks - some paid MAVEN consulting!!

Cheers,

sigi
Siegfried Goeschl
CTO
=================================

IT20one GmbH
mail: siegfried.goeschl@it20one.at
phone: +43-1-9900046
www.it20one.at


------- End of forwarded message -------

Siegfried Goeschl
CTO
=================================
IT20one GmbH
mail: siegfried.goeschl@it20one.at
phone: +43-1-9900046
fax: +43-1-52 37 888
www.it20one.at
Siegfried Goeschl
CTO
=================================

IT20one GmbH
mail: siegfried.goeschl@it20one.at
phone: +43-1-9900046
www.it20one.at