[Webtest] Cannot locate input / select field

Aatish Arora webtest@lists.canoo.com
Thu, 21 Aug 2003 09:01:35 -0700 (PDT)


Hi!

If possible can u paste the html code for it?

cheers!
Aatish

--- Saba Sundke <saba_sundke@persistent.co.in> wrote:
> I'm using the following step, but WebTest is unable
> to Locate the input
> field.
> 	<verifyinputfield stepid="Ensure that the subsite
> input box is set blank"
> 		name="subsite"
> 	value=""/>
> If I use the below XPath it works
> 	<verifyxpath stepid="Ensure that the subsite input
> box is set blank"
> 		xpath="//input[@name='subsite']"
> 	text=""/>
> 
> Similarly for verifying if select option is correct
> if I use XPath below, it
> works
> 		<verifyxpath stepid="Ensure that the state
> selectbox is at Colorodo"
>            	 		
> xpath="//select[@name='state']//option[@selected]"
> 			            text="Colorado(CO)"/>
> but not
>       <verifyselectfield stepid="Ensure that the
> state selectbox is
> Colorodo"
>                         name="state"
>                         value="CO"/>
> 
> There is no significant parser warning for the
> result (except summary
> attribute required for table). I'm able to open the
> result html in XPath
> Explorer. What is the issue?
> 
> - Saba
> 
> 
> _______________________________________________
> WebTest mailing list
> WebTest@lists.canoo.com
> http://lists.canoo.com/mailman/listinfo/webtest


=====
========================
THE FOUR STAGES OF LIFE:

1) You believe in Santa Claus.
2) You don't believe in Santa Claus.
3) You are Santa Claus.
4) You look like Santa Claus.
========================

__________________________________
Do you Yahoo!?
Yahoo! SiteBuilder - Free, easy-to-use web site design software
http://sitebuilder.yahoo.com