[Webtest] problem with verifylinks and followframe

Dierk Koenig webtest@lists.canoo.com
Tue, 1 Jun 2004 14:03:50 +0200


Hi,

have you tried selecting your frame with a direct <invoke>
instead of followframe?

cheers
Mittie

> -----Original Message-----
> From: webtest-admin@lists.canoo.com
> [mailto:webtest-admin@lists.canoo.com]On Behalf Of ilfrin
> Sent: Dienstag, 1. Juni 2004 13:38
> To: webtest@lists.canoo.com
> Subject: [Webtest] problem with verifylinks and followframe
> 
> 
> Hi,
> 
>    I have a problem with the verifylinks element, or with
>    understanding some other things perhaps ..
> 
>    I have a test that logs me to a page with a user/pass, then follows
>    a frame via <followframe/> and then in that frame it checks for the
>    title, text elements and that's ok it works, but now I added the
>    verifylinks step afterwards and the test crashes with a
> 
> com.canoo.webtest.engine.StepExecutionException: Unexpected 
> exception caught: com.meterware.httpunit.NoSuchFrameException: No 
> frame named calosc is currently active, Step: VerifyLinks at
> ...
> 
>    and I don't know what to do about it, I did an experiment and
>    removed the frames so that everything is in the first html (and
>    subsequently i removed the followframe step) and then the
>    verifylinks step works fine
> 
>    so the problem seems to be something with the frames ? aby idea how
>    to resolve it? thanks in advance for any suggestions ..
> 
> -- 
> 
>  ilfrin                          mailto:ilfrin@poczta.onet.pl
> 
> 
> _______________________________________________
> WebTest mailing list
> WebTest@lists.canoo.com
> http://lists.canoo.com/mailman/listinfo/webtest
>