[Webtest] Maven Canoo WebTest Plugin: Problems while creating a test summary report with Build 454

Dierk Koenig webtest@lists.canoo.com
Wed, 21 Jul 2004 12:51:54 +0200


OK, thanx for the investigation
Mittie

-----Original Message-----
From: webtest-admin@lists.canoo.com
[mailto:webtest-admin@lists.canoo.com]On Behalf Of Göschl,Siegfried
Sent: Mittwoch, 21. Juli 2004 12:35
To: webtest@lists.canoo.com
Subject: RE: [Webtest] Maven Canoo WebTest Plugin: Problems while
creating a test summary report with Build 454


Hi Mittie,

> This is because test reports get appended to the existing report file.
> As XML needs an enclosing root element, the Appender needs to parse
> the old file <and add his content as the last child of the parsed
> root. (Ok, a text-based append would also be possible and much faster...)

IMHO the report writing error could be a bug because

+) I'm running a single test (a single ANT file with a single testspec)
+) I did not specify a result file to be used
+) The docs state for the resultfile parameter - "Defines a commonly used
result file where test results are appended. This is useful to create
summary reports for more than one testspec. An individual result file for
each testspec is created if this parameter is not specified."

Therefore I never had a report file to be parsed and should never got a
SAXParseException ... :-)

On the other hand defining an result file explicitely did the trick and the
plugin now works like a charm.


Thanks,

Siegfried Goeschl







_______________________________________________
WebTest mailing list
WebTest@lists.canoo.com
http://lists.canoo.com/mailman/listinfo/webtest