[Webtest] Building WebTest

Erskine, Chris webtest@lists.canoo.com
Thu, 29 Jul 2004 14:34:49 -0500


This message is in MIME format. Since your mail reader does not understand
this format, some or all of this message may not be legible.

------_=_NextPart_001_01C475A3.1CCB48A0
Content-Type: text/plain

I am trying to build webTest.  I got the source from the CVS repository and 
put it into my directory but when I try to build it, I get an error from the
ant build scripts.
The error that I am getting is as follows.

____________
testInWork:

suite:

sampleUse:

BUILD FAILED
C:\a\sandbox\webtest\build.xml:148: The following error occurred while
executing this line:
C:\a\sandbox\webtest\build.xml:175: The following error occurred while
executing this line:
C:\a\sandbox\webtest\selftests\tests\build.xml:40: The following error
occurred while executing this line:
C:\a\sandbox\webtest\selftests\tests\build.xml:17: The following error
occurred while executing this line:
C:\a\sandbox\webtest\selftests\tests\TestSuite.xml:9: The following error
occurred while executing this line:
C:\a\sandbox\webtest\selftests\tests\sampleUse.xml:8: Could not create task
or type of type: testSpec.

Ant could not find the task or a class this task relies upon.

Somewhere, I do not have a value defined to point to the code that was
generated for at.  What values do I 
have to define to build and test webTest?


Chris Erskine
 
EDS Consulting Services
F5-EDS-001
2424 Garden of the Gods Rd
Colorado Springs, CO  80919
 
Phone: 719-535-6064
 
Phone:
mailto:chris.erskine@eds.com <mailto:chris.erskine@eds.com> 


------_=_NextPart_001_01C475A3.1CCB48A0
Content-Type: text/html
Content-Transfer-Encoding: quoted-printable

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//EN">
<HTML>
<HEAD>
<META HTTP-EQUIV=3D"Content-Type" CONTENT=3D"text/html; =
charset=3DUS-ASCII">
<META NAME=3D"Generator" CONTENT=3D"MS Exchange Server version =
5.5.2655.61">
<TITLE>Building WebTest</TITLE>
</HEAD>
<BODY>

<P ALIGN=3DLEFT><FONT SIZE=3D2 FACE=3D"Arial">I am trying to build =
webTest.&nbsp; I got the source from the CVS repository and</FONT> </P>

<P ALIGN=3DLEFT><FONT SIZE=3D2 FACE=3D"Arial">put it into my directory =
but when I try to build it, I get an error from the</FONT> <FONT =
SIZE=3D2 FACE=3D"Arial">ant</FONT> <FONT SIZE=3D2 FACE=3D"Arial">build =
scripts.</FONT></P>

<P ALIGN=3DLEFT><FONT SIZE=3D2 FACE=3D"Arial">The error that I am =
getting is as follows.</FONT></P>

<P ALIGN=3DLEFT><FONT SIZE=3D2 FACE=3D"Arial">____________</FONT></P>

<P ALIGN=3DLEFT><FONT SIZE=3D2 FACE=3D"Arial">testInWork:</FONT></P>

<P ALIGN=3DLEFT><FONT SIZE=3D2 FACE=3D"Arial">suite:</FONT></P>

<P ALIGN=3DLEFT><FONT SIZE=3D2 FACE=3D"Arial">sampleUse:</FONT></P>

<P ALIGN=3DLEFT><FONT SIZE=3D2 FACE=3D"Arial">BUILD FAILED</FONT></P>

<P ALIGN=3DLEFT><FONT SIZE=3D2 =
FACE=3D"Arial">C:\a\sandbox\webtest\build.xml:148: The following error =
occurred while executing this line:</FONT></P>

<P ALIGN=3DLEFT><FONT SIZE=3D2 =
FACE=3D"Arial">C:\a\sandbox\webtest\build.xml:175: The following error =
occurred while executing this line:</FONT></P>

<P ALIGN=3DLEFT><FONT SIZE=3D2 =
FACE=3D"Arial">C:\a\sandbox\webtest\selftests\tests\build.xml:40: The =
following error occurred while executing this line:</FONT></P>

<P ALIGN=3DLEFT><FONT SIZE=3D2 =
FACE=3D"Arial">C:\a\sandbox\webtest\selftests\tests\build.xml:17: The =
following error occurred while executing this line:</FONT></P>

<P ALIGN=3DLEFT><FONT SIZE=3D2 =
FACE=3D"Arial">C:\a\sandbox\webtest\selftests\tests\TestSuite.xml:9: =
The following error occurred while executing this line:</FONT></P>

<P ALIGN=3DLEFT><FONT SIZE=3D2 =
FACE=3D"Arial">C:\a\sandbox\webtest\selftests\tests\sampleUse.xml:8: =
Could not create task or type of type: testSpec.</FONT></P>

<P ALIGN=3DLEFT><FONT SIZE=3D2 FACE=3D"Arial">Ant could not find the =
task or a class this task relies upon.</FONT></P>

<P ALIGN=3DLEFT><FONT SIZE=3D2 FACE=3D"Arial">Somewhere, I do not have =
a value defined to point to the code that was generated for at.&nbsp; =
What values do I </FONT></P>

<P ALIGN=3DLEFT><FONT SIZE=3D2 FACE=3D"Arial">have to define to build =
and test webTest?</FONT></P>
<BR>

<P ALIGN=3DLEFT><A NAME=3D"_MailAutoSig"><FONT FACE=3D"Arial">Chris =
Erskine</FONT></A></P>

<P ALIGN=3DLEFT><FONT FACE=3D"Arial">&nbsp;</FONT></P>

<P ALIGN=3DLEFT><FONT SIZE=3D1 FACE=3D"Arial">EDS Consulting =
Services</FONT></P>

<P ALIGN=3DLEFT><FONT SIZE=3D1 FACE=3D"Arial">F5-EDS-001</FONT></P>

<P ALIGN=3DLEFT><FONT SIZE=3D1 FACE=3D"Arial">2424 Garden of the Gods =
Rd</FONT></P>

<P ALIGN=3DLEFT><FONT SIZE=3D1 FACE=3D"Arial">Colorado Springs, =
CO&nbsp; 80919</FONT></P>

<P ALIGN=3DLEFT><FONT FACE=3D"Arial">&nbsp;</FONT></P>

<P ALIGN=3DLEFT><FONT SIZE=3D1 FACE=3D"Arial">Phone: =
719-535-6064</FONT></P>

<P ALIGN=3DLEFT><FONT FACE=3D"Arial">&nbsp;</FONT></P>

<P ALIGN=3DLEFT><FONT SIZE=3D1 FACE=3D"Arial">Phone:</FONT></P>

<P ALIGN=3DLEFT><A HREF=3D"mailto:chris.erskine@eds.com"><U><FONT =
COLOR=3D"#0000FF" SIZE=3D1 =
FACE=3D"Arial">mailto:chris.erskine@eds.com</FONT></U></A></P>

<P ALIGN=3DLEFT></P>

</BODY>
</HTML>
------_=_NextPart_001_01C475A3.1CCB48A0--