[Webtest] how does followframe work ?

Marc Guillemot webtest@lists.canoo.com
Fri, 30 Jul 2004 11:23:23 +0200


Parker, Michael wrote:
 >
>>quite strange. I'm surprised not seeing any log messages from
>>httpunit. Have other log settings for it ? 
> 
> The answer referring to the source of httpunit I have in use here, is, there
> is no log4j inside of the httpunit-sources.

you're right. No idea what I have done to get messages like:

[zkyTestSpec] DEBUG (com.meterware.httpunit.HttpWebResponse:246) - field = text/html
[zkyTestSpec] DEBUG (com.meterware.httpunit.HttpWebResponse:244) - HttpWebResponse.addHeader
[zkyTestSpec] DEBUG (com.meterware.httpunit.HttpWebResponse:245) - key   = CONTENT-LENGTH
[zkyTestSpec] DEBUG (com.meterware.httpunit.HttpWebResponse:246) - field = -1
[zkyTestSpec] DEBUG (com.meterware.httpunit.HttpWebResponse:55) - HttpWebResponse 
[url=http://localhost:8080/jnCastor/content.do; headers=
[zkyTestSpec]    CONTENT-TYPE: text/html
[zkyTestSpec]    CONTENT-TYPE: text/html
[zkyTestSpec]    CONTENT-LENGTH: -1
[zkyTestSpec]    TRANSFER-ENCODING: chunked
[zkyTestSpec]    SERVER: Apache-Coyote/1.1
[zkyTestSpec]    EXPIRES: Fri, 30 Jul 2004 10:17:43 GMT
[zkyTestSpec]    DATE: Fri, 30 Jul 2004 09:17:42 GMT ]
[zkyTestSpec] DEBUG (com.meterware.httpunit.HttpWebResponse:56) - _responseCode = 200
[zkyTestSpec] DEBUG (com.meterware.httpunit.HttpWebResponse:57) - _responseMessage = OK

and afaik HttpWebResponse don't have 246 lines! I guess that my computer needs vacation as well.

Marc.