[Webtest] Click-o-matic issues

Dierk Koenig webtest@lists.canoo.com
Fri, 10 Sep 2004 15:24:59 +0200


> I am now getting a chance to look at Click-o-matic.  When I run it through
my application, the find that the first page displays fine.  When I go to
any of the additional pages, my graphics start to break.    The images are
scrambled in places and others are missing.

Chances are your server sends the images without proper content-type
response header.
For convenience we assume text/html then which results in images being sent
as text :-(
It appears we need more logic here.

> Is there a way in the log to display each incoming request, not just the
ones being processed by Click-o-matic?

I guess by "log" you mean the GUI textarea. This area will only display
processed pages.
There is another log that gets written to the console window displaying more
of the
technical information.
You can configure how much you want to see here by (un)commenting the lines
in the
log4j.properties file that you will find in the Click-O-Mat.jar. see also
http://webtest-community.canoo.com/wiki/space/Click-O-Mat/Features Logging.

> Also, can you handle multiple request streams at the same time?

We currently don't to keep things simple (esp. debugging) in the alpha
cycle.
We know that we face some performance drain by processing requests
in strict sequence. However, there are a lot of difficult issues to consider
when going multithreaded.

Do you need this feature for a special purpose?

cheers
Mittie