[Webtest] Click-o-matic issues

Philippe IMOUCHA webtest@lists.canoo.com
Mon, 13 Sep 2004 11:07:18 +0200


As you mention I have added the mime mapping to my tomcat configuration
ad restart the application
Nothing change same pb

Here is a little test case that I try to record but the browser doesn't
show the images while using the proxy while without the proxy it's fine!

<html>
<head>
  <meta http-equiv=3D"content-type" content=3D"text/html;
charset=3DISO-8859-1">
  <title>Click on a button</title>
</head>
<body>
  <IMG SRC=3D"../components/img/construction_1.gif"><br>
  <IMG SRC=3D"../components/img/construction_2.gif"><br>
  <IMG SRC=3D"../components/img/construction_3.gif"><br>
  <IMG SRC=3D"../components/img/construction_4.gif"><br>
</body>
</html>

Phil
------------------------------------
-----Original Message-----
From: webtest-admin@lists.canoo.com
[mailto:webtest-admin@lists.canoo.com] On Behalf Of Dierk Koenig
Sent: Friday, September 10, 2004 18:29
To: webtest@lists.canoo.com
Subject: RE: [Webtest] Click-o-matic issues

The content-type issue is not something you deal with in the application
itself.
It is a configuration issue with either how your webapp or your server
is
configured.

The server config or the WEB-INF/web.xml file of your application needs
to
tell the
server what content-type to send for what kind of files.
Example of a web.xml entry:

    <mime-mapping>
        <extension>gif</extension>
        <mime-type>image/gif</mime-type>
    </mime-mapping>

For production strength servers it is important have a proper mapping.
On test servers, that are not professionally managed, this is often
overseen.
Anyway, the closer your test environment is supposed to mirror your
production environment the more important it is to use production
config also on the test servers.

cheers
Mittie

> -----Original Message-----
> From: webtest-admin@lists.canoo.com
> [mailto:webtest-admin@lists.canoo.com]On Behalf Of Philippe IMOUCHA
> Sent: Freitag, 10. September 2004 15:49
> To: webtest@lists.canoo.com
> Subject: RE: [Webtest] Click-o-matic issues
>
>
> I have the same type of issue
> My webapp just refer to images in the html code using img tag!
> You mention that we must mention the content type.
> Can you tell us haw to do it with a JSP that generates a img tag in
the
> HTML?
>
> Phil
>
> ------------------------------------
> Netonomy
> Philippe IMOUCHA
> Application Group - Progam Management Director
> phil@netonomy.com
> 49-51, rue Ganneron
> 75018 PARIS
> France
> tel: +33 (0) 1 74 30 74 03
> fax: +33 (0) 1 74 30 74 41
> mobile: +33 (0) 6 11 48 35 34
> ------------------------------------
> -----Original Message-----
> From: webtest-admin@lists.canoo.com
> [mailto:webtest-admin@lists.canoo.com] On Behalf Of Dierk Koenig
> Sent: Friday, September 10, 2004 15:25
> To: webtest@lists.canoo.com
> Subject: RE: [Webtest] Click-o-matic issues
>
> > I am now getting a chance to look at Click-o-matic.  When I run it
> through
> my application, the find that the first page displays fine.  When I go
> to
> any of the additional pages, my graphics start to break.    The images
> are
> scrambled in places and others are missing.
>
> Chances are your server sends the images without proper content-type
> response header.
> For convenience we assume text/html then which results in images being
> sent
> as text :-(
> It appears we need more logic here.
>
> > Is there a way in the log to display each incoming request, not just
> the
> ones being processed by Click-o-matic?
>
> I guess by "log" you mean the GUI textarea. This area will only
display
> processed pages.
> There is another log that gets written to the console window
displaying
> more
> of the
> technical information.
> You can configure how much you want to see here by (un)commenting the
> lines
> in the
> log4j.properties file that you will find in the Click-O-Mat.jar. see
> also
> http://webtest-community.canoo.com/wiki/space/Click-O-Mat/Features
> Logging.
>
> > Also, can you handle multiple request streams at the same time?
>
> We currently don't to keep things simple (esp. debugging) in the alpha
> cycle.
> We know that we face some performance drain by processing requests
> in strict sequence. However, there are a lot of difficult issues to
> consider
> when going multithreaded.
>
> Do you need this feature for a special purpose?
>
> cheers
> Mittie
>
>
> _______________________________________________
> WebTest mailing list
> WebTest@lists.canoo.com
> http://lists.canoo.com/mailman/listinfo/webtest
>
>
> _______________________________________________
> WebTest mailing list
> WebTest@lists.canoo.com
> http://lists.canoo.com/mailman/listinfo/webtest
>

_______________________________________________
WebTest mailing list
WebTest@lists.canoo.com
http://lists.canoo.com/mailman/listinfo/webtest