[Webtest] Error trying to use build 516

Lisa Crispin webtest@lists.canoo.com
Tue, 28 Sep 2004 22:44:56 +0000


I installed the latest version (516) of WebTest, just because I like to keep current, I wasn't intending to use any of the new features yet.  I get this error when I try to run an existing test.  I'm not even wanting to use Groovy yet (although we do want to investigate it), and the documentation on the wiki says nothing extra is needed in the installation anyway.  I have JDK 1.4.2.  How do I fix this problem so I can use the new version?  Thanks, -- Lisa

LOCALCLASSPATH is c:\ant\apache-ant-1.6.0\lib\ant-launcher.jar
Buildfile: build.xml

canoo-taskdef:
Trying to override old definition of task sleep

BUILD FAILED
C:\java\eplan\build.xml:896: taskdef A class needed by class com.canoo.webtest.e
xtension.GroovyStep cannot be found: org/codehaus/groovy/control/CompilationFail
edException

Total time: 2 seconds
LOCALCLASSPATH is c:\ant\apache-ant-1.6.0\lib\ant-launcher.jar
Buildfile: build.xml