[Webtest] R1312: exception [clickbutton] java.lang.NoSuchMethodError: org.apache.comm

vikram shevde webtest@lists.canoo.com
Thu, 11 May 2006 16:00:56 +0000


All,

Thanks for replies to my previous posts. I just upgraded to the latest 
version of canoo, and also made some other non-canoo related changes to our 
application, and all of a sudden, i started getting the following exception:
*****************************************************************************
[clickbutton]  INFO (com.canoo.webtest.steps.Step) - Exception thrown from 
this class: java.lang.NoSuchMethodError
[clickbutton]  INFO (com.canoo.webtest.steps.Step) - Message was: 
org.apache.commons.collections.CollectionUtils.transform(Ljava/util/Collection;Lorg/apache/commons/collections/Transformer;)V
[clickbutton] ERROR (com.canoo.webtest.steps.Step) - Cannot handle 
unexpected exception in step ClickButton at 
D:\gol\src\golApp\golWebTest\resources\test\UseCases\testRFPCreation.xml:40: 
  with (taskName="clickbutton", label="Create RFA", description="Click on 
actual button to create the RFA")
[clickbutton] java.lang.NoSuchMethodError: 
org.apache.commons.collections.CollectionUtils.transform(Ljava/util/Collection;Lorg/apache/commons/collections/Transformer;)V
[clickbutton] 	at 
com.gargoylesoftware.htmlunit.javascript.ElementArray.get(ElementArray.java:247)
[clickbutton] 	at 
org.mozilla.javascript.ScriptableObject.getProperty(ScriptableObject.java:1312)
[clickbutton] 	at 
org.mozilla.javascript.ScriptRuntime.getObjectElem(ScriptRuntime.java:1303)
*************************************************************************
I tried looking at the source-code for HtmlUnit,Canoo's ClickButton class 
and also de-compiled the CollectionUtils class from the 
commons-collections-3-1.jar. It DOES have the method 
transform(Collection,Transformer), so am totally confused. I run our tests 
from inside WebLogic Workshop, using a external ant process( fork=true), and 
the same build file used to work with earlier versions too. I thought this 
might have something to do with the XercesImpl.jar thats in my ANT_HOME/lib 
directory( i use ant 1.6.5), and so replaced it with the XercesImpl shipped 
with Canoo...still no luck. Could someone please help me out?

Thanks in advance!

Vikram.