[Webtest] Name of step: emulateSetHiddenInputField

Marc Guillemot webtest@lists.canoo.com
Fri, 19 May 2006 05:39:51 -0700 (PDT)

probably the best alternative until now... but I'm still not fully satisfied


> What about forceXxx?
> Paul.
> Marc Guillemot wrote:
>> ok for the point: "hidden" is... hidden in the name of the step.
>> I'm not really happy with emulate, pseudo and simulate. Perhaps fakeXxx?
>> Marc.
>> Paul King wrote:
>>> Marc Guillemot wrote:
>>>> Hi,
>>>> I'm quite unhappy with the name of the field
>>>> emulateSetHiddenInputField.
>>>> Why "emulate"? Why not simply setHiddenInputField?
>>> If the user could normally trigger this by using some action then
>>> we should drop the emulate. But this can never be triggered directly
>>> by the user. It is only provided for when tricky javascript is not
>>> working. The ideal is that we get the javascript working so a longer
>>> ugly name is probably a good thing.
>>> Alternatives: pseudoXXX, simulateXXX
>>> Paul. 
View this message in context: http://www.nabble.com/Name+of+step%3A+emulateSetHiddenInputField-t1645497.html#a4468635
Sent from the WebTest forum at Nabble.com.