[Webtest] Name of step: emulateSetHiddenInputField

Dierk Koenig webtest@lists.canoo.com
Fri, 19 May 2006 07:39:10 -0700


to me, the only thing that's special about setting a hidden field
is that it's 'hidden'. Neither do I see that it is emulated nor forced in
any
way that's different from other setXXX steps.

I opt for 'setHiddenInputField'.

cheers
Mittie

> -----Original Message-----
> From: webtest-admin@lists.canoo.com
> [mailto:webtest-admin@lists.canoo.com]On Behalf Of Marc Guillemot
> Sent: Freitag, 19. Mai 2006 5:40
> To: webtest@lists.canoo.com
> Subject: Re: [Webtest] Name of step: emulateSetHiddenInputField
>
>
>
> probably the best alternative until now... but I'm still not
> fully satisfied
> ;-(
>
> Marc.
>
> > What about forceXxx?
> >
> > Paul.
> >
> > Marc Guillemot wrote:
> >> ok for the point: "hidden" is... hidden in the name of the step.
> >>
> >> I'm not really happy with emulate, pseudo and simulate.
> Perhaps fakeXxx?
> >>
> >> Marc.
> >>
> >> Paul King wrote:
> >>> Marc Guillemot wrote:
> >>>
> >>>> Hi,
> >>>>
> >>>> I'm quite unhappy with the name of the field
> >>>> emulateSetHiddenInputField.
> >>>>
> >>>> Why "emulate"? Why not simply setHiddenInputField?
> >>>
> >>> If the user could normally trigger this by using some action then
> >>> we should drop the emulate. But this can never be triggered directly
> >>> by the user. It is only provided for when tricky javascript is not
> >>> working. The ideal is that we get the javascript working so a longer
> >>> ugly name is probably a good thing.
> >>>
> >>> Alternatives: pseudoXXX, simulateXXX
> >>>
> >>> Paul.
> --
> View this message in context:
http://www.nabble.com/Name+of+step%3A+emulateSetHiddenInputField-t1645497.ht
ml#a4468635
Sent from the WebTest forum at Nabble.com.

_______________________________________________
WebTest mailing list
WebTest@lists.canoo.com
http://lists.canoo.com/mailman/listinfo/webtest