[Webtest] Host of problems in building Canoo Webtest

Jon Poulton [kinomi] webtest@lists.canoo.com
Fri, 26 May 2006 11:19:47 +0100


Hi Marc,
Thanks for the reply.

On the missing jar files; I tried running the fetchDependencies task
separately from the build, as well as doing the full build itself. I seem to
get a set of warnings from the build no matter how I try and do this. The
warnings are of the form:

fetchDependencies:
[artifact:dependencies] Downloading:
groovy/groovy-all-1.0-jsr/05/groovy-all-1.0-jsr-05.pom
[artifact:dependencies] [WARNING] Unable to get resource from repository
webtest_dependencies_snapshot (file://C:\Java\canoo/m2/repository/)
[artifact:dependencies] Downloading:
groovy/groovy-all-1.0-jsr/05/groovy-all-1.0-jsr-05.pom
[artifact:dependencies] [WARNING] Unable to get resource from repository
central (http://repo1.maven.org/maven2)
[artifact:dependencies] Downloading:
groovy/groovy-all-1.0-jsr/05/groovy-all-1.0-jsr-05.pom
[artifact:dependencies] [WARNING] Unable to get resource from repository
central (http://repo1.maven.org/maven2)

This is the same on both the Linux and Windows machines I've tried the build
on. I've tried turning off the firewall on Windows in case that was the
problem, but it's made no difference at all. The problem with these warnings
(which are scattered throughout the results of running the build file) is
that there is no information on whether this will stop a successful build or
not - if this is the cause of the build failure, then really the build
should terminate at this point and give an error message stating "Could not
get jar file blah blah: build failed", but as the build just churns on after
this point, I'm left wondering if I should ignore the warnings, or not?

On the Eclipse problems; I did actually find a number of jar files under
various folders inside WEBTEST_HOME/m2/repository, and added them to my
classpath inside Eclipse (Sorry, I should have mentioned this in my first
email), but I still get compilation errors - this is truly bizarre as when I
do a build manually with your ant build file no compilation errors are given
at all. I really don't know what's going on there, and frankly I'd feel a
lot more comfortable if all the jar files I required were provided with the
release, rather than have some provided, and some automatically downloaded
via maven; a tool I'm not familiar with. Could you list the locations of the
jar files needed for a build please? As far as I know they're under /lib and
/m2/repository, is that all?

On the failing pdf tests; I've tried this on both Windows and Linux machines
with the same result. More of a concern is why the build *still* fails, even
after I have removed the failing tests?

On the missing webtest.dtd file; running a search over everything under
WEBTEST_HOME actually located 3 different files; one was the zero byte file
I mentioned in the first mail, and the other two were under selftests/config
and releasetests/config, and were both incomplete dtd files, one of which
contained what looked like a couple of placeholders. Unfortunately I need
the webtest.dtd generated, because of the additional classes I will be
adding to webtest, so I'm assuming for now that the only way to get this
file generated is to get a successful build of webtest done.

Thanks for your help so far,

Jon



-----Original Message-----
From: webtest-admin@gate2.canoo.com [mailto:webtest-admin@gate2.canoo.com]
On Behalf Of Marc Guillemot
Sent: 26 May 2006 10:45
To: webtest@gate2.canoo.com
Subject: Re: [Webtest] Host of problems in building Canoo Webtest


Hi Jon,

sorry for the difficulties building webtest from source. I agree that our
build process is too complicated (I have my self too often problems).

> So, I have a number of questions.
> 1)       Where are all the missing jar files, and why are they not
> included in the release?

Webtest has started using a maven pom for its dependencies. When the
fetchDependencies target is run, the dependencies are downloaded from a
maven repository and saved in your local repository. To make them available
to eclipse, you can add them manually (they must be in
YOUR_HOME_DIR/.m2/repository) or install maven 2 and use the eclipse plugin
to generate your .classpath file [1]. Because the move to the pom is not
complete, you still need to add some jars manually to the classpath

> 2)       Why do the pdf related tests repeatedly fail, and why does the
> build continue to fail after I'd apparently removed the tests?

no idea. They run correctly on my Linux and Windows computers as well as on
the build server and on the computers of the other committers. You need to
investigate more.

> 3)       Why is there no task in the ant build file that will allow me to
> build Webtest without having to run all of these tests?

it's probably a feature ;-(
Personally I often add the classes generated by Eclipse to my classpath when
I try to develop something new with WebTest. First when it works correctly I
run the heavy build process.

> 4)       Why is the generated Webtest.dtd completely empty after the
> build? Is it because the build failed because of the failing tests?

I've seen this once too. As far as I remember the DTD is generated with the
documentation. It's probably the wrong place.

I hope my answers help you going further.

Marc.

[1] http://maven.apache.org/plugins/maven-eclipse-plugin/overview.html
--
View this message in context:
http://www.nabble.com/Host+of+problems+in+building+Canoo+Webtest-t1685787.ht
ml#a4573340
Sent from the WebTest forum at Nabble.com.

_______________________________________________
WebTest mailing list
WebTest@lists.canoo.com
http://lists.canoo.com/mailman/listinfo/webtest