[Webtest] [webtest][JIRA] Created: (WT-201) rename emulateXXX steps to forceXXX steps: forceHiddenInputField and forceInputFieldAttribute

Paul King (JIRA) webtest@lists.canoo.com
Fri, 2 Jun 2006 11:44:27 +0200 (CEST)


rename emulateXXX steps to forceXXX steps: forceHiddenInputField and forceInputFieldAttribute
---------------------------------------------------------------------------------------------

         Key: WT-201
         URL: http://webtest-community.canoo.com/jira/browse/WT-201
     Project: WebTest
        Type: Task

    Reporter: Paul King
 Assigned to: Paul King 



I was planning to rename the emulate steps as follows:

emulateSetHiddenInputField -> forceHiddenInputField
emulateSetInputFieldAttribute -> forceInputFieldAttribute

This is a slight improvement with regard to what the steps do.
Aliases will exist for the previous names.

If testers wish to ignore the difference between browser
possible actions and forced (around/behind) the browser
simulated actions, then they can simply add set versions
of these steps into their webtesttaskdef.properties file:

setHiddenInputField
setInputFieldAttribute


-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://webtest-community.canoo.com/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira