[Webtest] Problems with clickLink

Dierk Koenig webtest@lists.canoo.com
Thu, 8 Jun 2006 08:25:27 +0200


This is a multi-part message in MIME format.

------=_NextPart_000_000C_01C68AD5.18BAA4B0
Content-Type: text/plain;
	charset="iso-8859-1"
Content-Transfer-Encoding: 8bit

Hi Juliane,

what do you mean by 'compile' ? Starting the WebTest script via 'ant' ?

Is the test working when you omit the href attribute?

If not, could you please paste the error log into the mail?

cheers
Mittie
  -----Original Message-----
  From: webtest-admin@lists.canoo.com
[mailto:webtest-admin@lists.canoo.com]On Behalf Of Juliane Botelho
  Sent: Donnerstag, 8. Juni 2006 4:01
  To: webtest@lists.canoo.com
  Subject: Re: [Webtest] Problems with clickLink


  Hi Mittie,

  thanks!!!

  I've tried using "&", but it didn't work. when I compiled, appeared a
lot of codes that the window couldn't show the most part of the
errors/warnings. I think they are some canoo's source code.
  When I checked "result.xml", it shows that this step had failed.

  When I wrote href wrong, the canoo identifies that the link bellow is
available:
  href="servletacompanhamentoprocesso
  .do?acao=telaRegistrarAndamento&codFuncionalidade=25", but when I use it
in clickLink

  But the compiler identifies the error at &, asking to change it for ';'.

  I've changed a lot this code, but nothing works. I have no idea. :(

  Regards
  --
  Juliane Botelho
  Graduando em Engenharia da Computação
  Escola Politécnica - UPE

------=_NextPart_000_000C_01C68AD5.18BAA4B0
Content-Type: text/html;
	charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META http-equiv=3DContent-Type content=3D"text/html; =
charset=3Diso-8859-1">
<META content=3D"MSHTML 6.00.2900.2873" name=3DGENERATOR></HEAD>
<BODY>
<DIV><SPAN class=3D993332106-08062006><FONT face=3DArial color=3D#0000ff =
size=3D2>Hi=20
Juliane,</FONT></SPAN></DIV>
<DIV><SPAN class=3D993332106-08062006><FONT face=3DArial color=3D#0000ff =

size=3D2></FONT></SPAN>&nbsp;</DIV>
<DIV><SPAN class=3D993332106-08062006><FONT face=3DArial color=3D#0000ff =
size=3D2>what=20
do you mean by 'compile' ? Starting the WebTest script via 'ant'=20
?</FONT></SPAN></DIV>
<DIV><SPAN class=3D993332106-08062006><FONT face=3DArial color=3D#0000ff =

size=3D2></FONT></SPAN>&nbsp;</DIV>
<DIV><SPAN class=3D993332106-08062006><FONT face=3DArial color=3D#0000ff =
size=3D2>Is the=20
test working when you omit the href attribute?</FONT></SPAN></DIV>
<DIV><SPAN class=3D993332106-08062006><FONT face=3DArial color=3D#0000ff =

size=3D2></FONT></SPAN>&nbsp;</DIV>
<DIV><SPAN class=3D993332106-08062006><FONT face=3DArial color=3D#0000ff =
size=3D2>If=20
not, could you please paste the error log into the =
mail?</FONT></SPAN></DIV>
<DIV><SPAN class=3D993332106-08062006><FONT face=3DArial color=3D#0000ff =

size=3D2></FONT></SPAN>&nbsp;</DIV>
<DIV><SPAN class=3D993332106-08062006><FONT face=3DArial color=3D#0000ff =

size=3D2>cheers</FONT></SPAN></DIV>
<DIV><SPAN class=3D993332106-08062006><FONT face=3DArial color=3D#0000ff =

size=3D2>Mittie</FONT></SPAN></DIV>
<BLOCKQUOTE=20
style=3D"PADDING-LEFT: 5px; MARGIN-LEFT: 5px; BORDER-LEFT: #0000ff 2px =
solid">
  <DIV class=3DOutlookMessageHeader dir=3Dltr align=3Dleft><FONT =
face=3DTahoma=20
  size=3D2>-----Original Message-----<BR><B>From:</B>=20
  webtest-admin@lists.canoo.com =
[mailto:webtest-admin@lists.canoo.com]<B>On=20
  Behalf Of </B>Juliane Botelho<BR><B>Sent:</B> Donnerstag, 8. Juni 2006 =

  4:01<BR><B>To:</B> webtest@lists.canoo.com<BR><B>Subject:</B> Re: =
[Webtest]=20
  Problems with clickLink<BR><BR></FONT></DIV>Hi=20
  Mittie,<BR><BR>thanks!!!<BR><BR>I've tried using "&amp;amp;", but it =
didn't=20
  work. when I compiled, appeared a lot of codes that the window =
couldn't show=20
  the most part of the errors/warnings. I think they are some canoo's =
source=20
  code. <BR>When I checked "result.xml", it shows that this step had =
failed.=20
  <BR><BR>When I wrote href wrong, the canoo identifies that the link =
bellow is=20
  available:<BR>href=3D"servletacompanhamentoprocesso=20
  <DIV>.do?acao=3DtelaRegistrarAndamento&amp;codFuncionalidade=3D25", =
but when I use=20
  it in clickLink<BR><BR>But the compiler identifies the error at &amp;, =
asking=20
  to change it for ';'.<BR><BR>I've changed a lot this code, but nothing =
works.=20
  I have no idea. :(<BR><BR>Regards</DIV>-- <BR>Juliane =
Botelho<BR>Graduando em=20
  Engenharia da Computa=E7=E3o<BR>Escola Polit=E9cnica - UPE =
</BLOCKQUOTE></BODY></HTML>

------=_NextPart_000_000C_01C68AD5.18BAA4B0--