[Webtest] webtest reports (was: memory allocation)

Van webtest@lists.canoo.com
Sun, 18 Jun 2006 11:50:32 -0700


On 6/18/06, Dierk Koenig <dierk.koenig@canoo.com> wrote:
> Have you setup your installation like described in
> http://webtest.canoo.com/webtest/manual/install.html#Setup
> ?
>
> If so, the html report should be generated automatically
> in your reporting dir.

No. I believe our current setup was derived from example webtest
support in AppFuse, but, I do have a full recent build of webtest
downloaded. So, I will take a look at that and upgrade my build
process accordingly. If the AppFuse example build logic included
report generation, I must have accidentally removed that part when
massaging the setup for my own project.

> WebTest first generates an XML result in the reporting dir.
> After the tests have finished, the build.xml executes an
> XSLT task to apply an XSL stylesheet to the XML that
> spits out the HTML report. You console output should
> show a respective line at the very end.

I do have the XML result file. I'm missing the build logic to do the
XSL transformation. Sounds like I can find an example of ANT build
logic and an XSL stylesheet to do the transformation in the webtest
download directory. I'll check that out.

> If the above doesn't help, please send your console output
> (including how you started the process).

Thanks for the offer to help, but, I'm certain it is a pilot error
now. I'll take a good look at the sample build setup that is
incorporated in the webtest download and update our own build process
accordingly.

Cheers, Van

-- 
- Mike "Van" Riper
  van.riper@gmail.com