[Webtest] Connection timed out error

Marc Guillemot Marc Guillemot <mguillemot@yahoo.fr>
Tue, 21 Nov 2006 07:05:56 -0800 (PST)


Hi,

can you provide the whole stack trace that you get on the console? I could
imagine that the timeout doesn't come from the clickLink but a background
working task or an other window.

Btw, perhaps can you identify the link you click with something else than
href. Most of the time this is not the best solution to identify a link as
it uses an "implementation detail".

Additional question as you seem to write test for Air New Zealand: can I add
it to the (perhaps one day coming) "WebTest users" page?

Marc.


John and Pip wrote:
> 
> Hi,
> 
> I am running through the Air NZ flight booking process and when I get to
> the
> final step of confirmation, I get this error:
> 
>             <step>
>                 <parameter name="description" value="Submit"/>
>                 <parameter name="href"
> value="javascript:pleaseWait();calFormChecksum();MM_findObj('reviewAndPurchaseCashForm').submit();"/>
>                 <parameter name="resultFilename"
> value="response_1164065340027_clickLink.html"/>
>                 <parameter name="taskName" value="clickLink"/>
>                 <result>
>                     <failed duration="32272"/>
>                 </result>
>             </step>
> 
> with more detail at the bottom of the results:
> 
> <failure message="com.canoo.webtest.engine.StepFailedException:
> Step[clickLink &quot;Submit&quot; (47/50)]: Script error loading page
> executing webtest at: clickLink Wrapped
> com.gargoylesoftware.htmlunit.ScriptException: Connection timed out:
> connect
> (Wrapper definition for javascript url#1)&#xa;Source
> code:&#xa;GargoyleWrapper7(), Step: ClickLink at
> C:\WebTest\doc\ISIS\tempTest.xml:88:  with
> (resultFilename=&quot;response_1164065340027_clickLink.html&quot;,
> taskName=&quot;clickLink&quot;)"/>
> 
> The submission of the previous page must have worked because I get an
> E-Ticket generated, but the html captured by WebTest for the step in
> response_1164065340027_clickLink.html shows the same page as the previous
> step i.e. the payment page not the confirmation page.
> 
> 
> I have my timeout set to 120 seconds and as you can see it fails in 32
> seconds. When I run the process in a browser that step is by far the
> slowest
> in the process. The previous steps, which all succeed in WebTest with
> durations of 2 to 7 seconds, take a couple of seconds and this one takes
> 10
> seconds and sometimes more, but it still doesn't seem like a genuine
> timeout.
> 
> Here are the config settings I am using:
> 
>         <config>
>             <parameter name="protocol" value="http"/>
>             <parameter name="summary" value="yes"/>
>             <parameter name="saveresponse" value="yes"/>
>             <parameter name="timeout" value="120"/>
>             <parameter name="haltonerror" value="yes"/>
>             <parameter name="resultfile" value="results.xml"/>
>             <parameter name="port" value="57106"/>
>             <parameter name="showhtmlparseroutput" value="no"/>
>             <parameter name="autorefresh" value="yes"/>
>             <parameter name="resultpath"
> value="C:\WebTest\doc\ISIS\webtest-results"/>
>             <parameter name="host" value="aklia781"/>
>             <parameter name="haltonfailure" value="yes"/>
>             <parameter name="basepath" value="/isbook_en_NZ/book/"/>
>             <parameter name="saveprefix" value="response"/>
>         </config>
> 
> Unfortunately you can't duplicate this as the public site has anti-robot
> stuff so I'm running in a private test environment.
> 
> I get same result in version R_1389 and R_1438 of WebTest.
> 
> Can anyone give me any advise on how to track this one down (I am not a
> java
> programmer).
> 
> thanks and regards,
>            John
> 
> 

-- 
View this message in context: http://www.nabble.com/Connection-timed-out-error-tf2676032.html#a7472836
Sent from the WebTest mailing list archive at Nabble.com.