[Webtest] build the sources

Marc Guillemot Marc Guillemot <mguillemot@yahoo.fr>
Wed, 20 Dec 2006 03:34:13 -0800 (PST)


Hi Michael,

this is a classpath issue. To be sure to have it set correctly, use the
provided script:

bin/webtest.sh full

Marc.


Michael Habbert wrote:
> 
> Hi Marc,
> I started the build of the webtest-svn-sources:
> 
> habbert@bendera svn_webtest> ant full
> ANT_OPTS: -Xmx640m -Dhttp.proxyHost=wwwcache -Dhttp.proxyPort=3128 
> -Dbuild.compiler=jikes
> ANT_ARGS:
> Buildfile: build.xml
> 
> clean:
> 
> [...]
> 
>       [exec] BUILD SUCCESSFUL
>       [exec] Total time: 2 seconds
> 
> prepareInstallationTestDir:
>      [unzip] Expanding: 
> /usr/local/projekte/common/svn_webtest/deploy/build.zip into 
> /usr/local/projekte/common/svn_webtest/build/installTest
> 
> testMyCustomStep:
> 
> fetchDependencies:
> [artifact:dependencies] Downloading: 
> groovy/groovy-all-1.0-jsr/06/groovy-all-1.0-jsr-06.pom
> [artifact:dependencies] [WARNING] Unable to get resource from repository 
> webtest_dependencies_snapshot 
> (file:///usr/local/projekte/common/svn_webtest/m2/repository/)
> [artifact:dependencies] Downloading: 
> groovy/groovy-all-1.0-jsr/06/groovy-all-1.0-jsr-06.pom
> [artifact:dependencies] [WARNING] Unable to get resource from repository 
> central (http://repo1.maven.org/maven2)
> [artifact:dependencies] Downloading: 
> groovy/groovy-all-1.0-jsr/06/groovy-all-1.0-jsr-06.pom
> [artifact:dependencies] [WARNING] Unable to get resource from repository 
> central (http://repo1.maven.org/maven2)
> Trying to override old definition of task groovy
> 
> clover.present:
> 
> test.init:
> 
> runWebappAgainstJetty:
>       [echo] Result path will be: build/selftests/reports
> 
> isSelftestServerAlreadyRunning:
> 
> stopSelftestServer:
> 
> init:
> 
> start:
> 
> launchMyCustomStep:
>      [mkdir] Created dir: 
> /usr/local/projekte/common/svn_webtest/build/myCustomStep
>       [copy] Copying 6 files to 
> /usr/local/projekte/common/svn_webtest/build/myCustomStep
>       [copy] Copying 1 file to 
> /usr/local/projekte/common/svn_webtest/build/myCustomStep/src/test/webtest
>       [exec] Will use /usr/local/java/j2sdk1.4.2_10/bin/java
>       [exec] Buildfile: build.xml
>       [exec]   [typedef] Could not load definitions from resource 
> org/apache/maven/artifact/ant/antlib.xml. It could not be found.
> 
>       [exec] BUILD FAILED
>       [exec] 
> /usr/local/projekte/common/svn_webtest/build/myCustomStep/build.xml:29: 
> Could not create task or type of type: urn:maven-artifact-ant:pom.
> 
>       [exec] Ant could not find the task or a class this task relies upon.
> 
>       [exec] This is common and has a number of causes; the usual
>       [exec] solutions are to read the manual pages then download and
>       [exec] install needed JAR files, or fix the build file:
>       [exec]  - You have misspelt 'urn:maven-artifact-ant:pom'.
>       [exec]    Fix: check your spelling.
>       [exec]  - The task needs an external JAR file to execute
>       [exec]      and this is not found at the right place in the
> classpath.
>       [exec]    Fix: check the documentation for dependencies.
>       [exec]    Fix: declare the task.
>       [exec]  - The task is an Ant optional task and the JAR file and/or 
> libraries
>       [exec]      implementing the functionality were not found at the 
> time you
>       [exec]      yourself built your installation of Ant from the Ant 
> sources.
>       [exec]    Fix: Look in the ANT_HOME/lib for the 'ant-' JAR 
> corresponding to the
>       [exec]      task and make sure it contains more than merely a 
> META-INF/MANIFEST.MF.
>       [exec]      If all it contains is the manifest, then rebuild Ant 
> with the needed
>       [exec]      libraries present in ${ant.home}/lib/optional/ , or 
> alternatively,
>       [exec]      download a pre-built release version from apache.org
>       [exec]  - The build file was written for a later version of Ant
>       [exec]    Fix: upgrade to at least the latest release version of Ant
>       [exec]  - The task is not an Ant core or optional task
>       [exec]      and needs to be declared using <taskdef>.
>       [exec]  - You are attempting to use a task defined using
>       [exec]     <presetdef> or <macrodef> but have spelt wrong or not
>       [exec]    defined it at the point of use
> 
>       [exec] Remember that for JAR files to be visible to Ant tasks 
> implemented
>       [exec] in ANT_HOME/lib, the files must be in the same directory or 
> on the
>       [exec] classpath
> 
>       [exec] Please neither file bug reports on this problem, nor email
> the
>       [exec] Ant mailing lists, until all of these causes have been 
> explored,
>       [exec] as this is not an Ant bug.
> 
>       [exec] Total time: 0 seconds
> 
> BUILD FAILED
> /usr/local/projekte/common/svn_webtest/build.xml:977: The following 
> error occurred while executing this line:
> /usr/local/projekte/common/svn_webtest/build.xml:1129: The following 
> error occurred while executing this line:
> /usr/local/projekte/common/svn_webtest/build.xml:1035: The following 
> error occurred while executing this line:
> /usr/local/projekte/common/svn_webtest/build.xml:679: The following 
> error occurred while executing this line:
> /usr/local/projekte/common/svn_webtest/build.xml:1057: exec returned: 1
> 
> Total time: 7 minutes 47 seconds
> 
> So, what can I do to finish the build?
> 
> Thanks
> Michael Habbert
> _______________________________________________
> WebTest mailing list
> WebTest@lists.canoo.com
> http://lists.canoo.com/mailman/listinfo/webtest
> 
> 

-- 
View this message in context: http://www.nabble.com/webtest-cannot-handle-the-lack-of-a-secure-certificate-in-our-test-environment-tf2791697.html#a7988521
Sent from the WebTest mailing list archive at Nabble.com.