[Webtest] the latest build.zip is missing xalan hence xslt report generation fails (and webtest.dtd missing?)

Denis N. Antonioli Denis N. Antonioli" <denis.antonioli@canoo.com
Tue, 3 Apr 2007 23:30:18 +0200


--Apple-Mail-3--239876670
Content-Transfer-Encoding: 7bit
Content-Type: text/plain;
	charset=US-ASCII;
	delsp=yes;
	format=flowed

Hi John

On 30 mars 07, at 01:01, John and Pip wrote:

> Hi,
>
> I notice the latest build.zip doesn't have xalan in lib folder. My  
> run fails when trying to generate reports until I add back in  
> xalan-2.6.0.jar from the older webtest build. The error message is  
> "Xalan missing on classpath. Put xalan.jar and xerces.jar to ant/lib."
>
> I would have thought the self-tests would also fail as they check  
> for this condition, but I'm afraid I have never set these up to run  
> so I'm just guessing.
>
> What am I doing wrong?


which java version are you using?

Java 1.4 and 1.5 both come with some version of xalan and it isn't  
necessary to provide it.
See for example <http://ant.apache.org/manual/CoreTasks/style.html>


Best
	dna

-- 
Even progress takes its time.
   -- Oliver Evans


--Apple-Mail-3--239876670
Content-Transfer-Encoding: quoted-printable
Content-Type: text/html;
	charset=ISO-8859-1

<HTML><BODY style=3D"word-wrap: break-word; -khtml-nbsp-mode: space; =
-khtml-line-break: after-white-space; ">Hi John<DIV><BR =
class=3D"khtml-block-placeholder"></DIV><DIV><DIV><DIV>On 30 mars 07, at =
01:01, John and Pip wrote:</DIV><BR =
class=3D"Apple-interchange-newline"><BLOCKQUOTE type=3D"cite"><DIV =
id=3D"mb_0">Hi,<BR><BR>I notice the latest build.zip doesn't have xalan =
in lib folder. My run fails when trying to generate reports until I add =
back in xalan-2.6.0.jar from the older webtest build. The error message =
is "Xalan missing on classpath. Put xalan.jar and xerces.jar to =
ant/lib."<BR><BR>I would have thought the self-tests would also fail as =
they check for this condition, but I'm afraid I have never set these up =
to run so I'm just guessing.<BR><BR> What am I doing =
wrong?<BR></DIV></BLOCKQUOTE><DIV><BR =
class=3D"khtml-block-placeholder"></DIV><DIV><BR =
class=3D"khtml-block-placeholder"></DIV><DIV>which java version are you =
using?</DIV><DIV><BR class=3D"khtml-block-placeholder"></DIV><DIV>Java =
1.4 and 1.5 both come with some version of xalan and it isn't necessary =
to provide it.</DIV><DIV>See for example &lt;<A =
href=3D"http://ant.apache.org/manual/CoreTasks/style.html">http://ant.apac=
he.org/manual/CoreTasks/style.html</A>&gt;</DIV><BR></DIV><DIV><BR =
class=3D"khtml-block-placeholder"></DIV><DIV>Best</DIV><DIV><SPAN =
class=3D"Apple-tab-span" style=3D"white-space:pre">	=
</SPAN>dna</DIV><BR><DIV> <P style=3D"margin: 0.0px 0.0px 0.0px =
0.0px"><FONT face=3D"Helvetica" size=3D"3" style=3D"font: 12.0px =
Helvetica">--<SPAN class=3D"Apple-converted-space">=A0</SPAN></FONT></P> =
<P style=3D"margin: 0.0px 0.0px 0.0px 0.0px"><FONT face=3D"Helvetica" =
size=3D"3" style=3D"font: 12.0px Helvetica">Even progress takes its =
time.</FONT></P> <P style=3D"margin: 0.0px 0.0px 0.0px 0.0px"><FONT =
face=3D"Helvetica" size=3D"3" style=3D"font: 12.0px Helvetica"><SPAN =
class=3D"Apple-converted-space">=A0 </SPAN>-- Oliver Evans</FONT></P>  =
</DIV><BR></DIV></BODY></HTML>=

--Apple-Mail-3--239876670--