[Webtest] the latest build.zip is missing xalan hence xslt report generation fails (and webtest.dtd missing?)

Denis N. Antonioli Denis N. Antonioli" <denis.antonioli@canoo.com
Wed, 4 Apr 2007 15:23:25 +0200


On 4 avr. 07, at 06:35, Paul King wrote:

> Denis N. Antonioli wrote:
>> Hi John
>> On 30 mars 07, at 01:01, John and Pip wrote:
>>> Hi,
>>>
>>> I notice the latest build.zip doesn't have xalan in lib folder.  
>>> My run fails when trying to generate reports until I add back in  
>>> xalan-2.6.0.jar from the older webtest build. The error message  
>>> is "Xalan missing on classpath. Put xalan.jar and xerces.jar to  
>>> ant/lib."
>>>
>>> I would have thought the self-tests would also fail as they check  
>>> for this condition, but I'm afraid I have never set these up to  
>>> run so I'm just guessing.
>>>
>>> What am I doing wrong?
>> which java version are you using?
>> Java 1.4 and 1.5 both come with some version of xalan and it isn't  
>> necessary to provide it.
>> See for example <http://ant.apache.org/manual/CoreTasks/style.html>
>
>> From memory, Java 1.4 includes a subset of xalan's functionality,
> so removing xalan as a dependency may actually not be the thing to do.
> I'll see if I can clarify this.

But that at least explains why the build server didn't break ;-)

I just had quick look at the history of the pom and could not find  
any entry for xalan.
Either xalan came indirectly through a dependency, or it has been  
removed from the build.zip for more than 9 month.

John, from which version of the build are you upgrading?


Best
	dna

-- 
And I'm urging every CEO to make sure it [Windows] runs really
slowly, so people stop using that stuff.
   -- Scott McNealy, chairman & CEO of Sun