[Webtest] the latest build.zip is missing xalan hence xslt report generation fails (and webtest.dtd missing?)

John and Pip John and Pip" <pipandjohn@gmail.com
Thu, 5 Apr 2007 08:41:15 +1200


------=_Part_39348_21696588.1175719275770
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

I don't know whether this helps, but having tidied up as best I can my java
path, webtest from DOS now works without xalan in webtest\lib including the
xslt part, but eclipse gives the "Xalan missing on classpath" error, despite
saying in the console title bar that it's java is in the same place as the
dos java_home.

In preferences under java/classpath variables JRE_LIB points to rt.jar in
the lib folder of the java folder - is that correct?

Under Ant/Runtime/Global entries I have the webtest\lib folder but seem to
always have to explicitly also add xalan-2.6.0.jar and xercesImpl-2.6.2.jar.
Is that normal?

regards,
         John

On 4/5/07, Paul King <paulk@asert.com.au> wrote:
>
> Denis N. Antonioli wrote:
> > I just had quick look at the history of the pom and could not find any
> > entry for xalan.
> > Either xalan came indirectly through a dependency, or it has been
> > removed from the build.zip for more than 9 month.
>
> Must have been an indirect dependency then.
> R_1498 is dated 22 Feb 2007 and it includes xalan-2.6.0.
>
> Paul.
>
> _______________________________________________
> WebTest mailing list
> WebTest@lists.canoo.com
> http://lists.canoo.com/mailman/listinfo/webtest
>

------=_Part_39348_21696588.1175719275770
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

I don&#39;t know whether this helps, but having tidied up as best I can my java path, webtest from DOS now works without xalan in webtest\lib including the xslt part, but eclipse gives the &quot;Xalan missing on classpath&quot; error, despite saying in the console title bar that it&#39;s java is in the same place as the dos java_home.
<br><br>In preferences under java/classpath variables JRE_LIB points to rt.jar in the lib folder of the java folder - is that correct?<br><br>Under Ant/Runtime/Global entries I have the webtest\lib folder but seem to always have to explicitly also add 
xalan-2.6.0.jar and xercesImpl-2.6.2.jar. Is that normal? <br><br>regards,<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; John<br><br><div><span class="gmail_quote">On 4/5/07, <b class="gmail_sendername">Paul King</b> &lt;<a href="mailto:paulk@asert.com.au">
paulk@asert.com.au</a>&gt; wrote:</span><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">Denis N. Antonioli wrote:<br>&gt; I just had quick look at the history of the pom and could not find any
<br>&gt; entry for xalan.<br>&gt; Either xalan came indirectly through a dependency, or it has been<br>&gt; removed from the build.zip for more than 9 month.<br><br>Must have been an indirect dependency then.<br>R_1498 is dated 22 Feb 2007 and it includes 
xalan-2.6.0.<br><br>Paul.<br><br>_______________________________________________<br>WebTest mailing list<br><a href="mailto:WebTest@lists.canoo.com">WebTest@lists.canoo.com</a><br><a href="http://lists.canoo.com/mailman/listinfo/webtest">
http://lists.canoo.com/mailman/listinfo/webtest</a><br></blockquote></div><br>

------=_Part_39348_21696588.1175719275770--