[Webtest] Out of memory when running WebTest

Tim Miller Tim Miller" <tmiller@edgedynamics.com
Wed, 18 Apr 2007 10:38:28 -0700


This is a multi-part message in MIME format.

------_=_NextPart_001_01C781E0.5F9A2E78
Content-Type: text/plain;
	charset="us-ascii"
Content-Transfer-Encoding: quoted-printable

I have a project which contains 12 WebTests, each WebTest contains
approximately 50-60 steps. I can only run 4 of the WebTests at a time.
Anything more and I get an out of memory. Each WebTest seems to use
about .1 GB of memory when it runs, the memory usage never goes down
once each WebTest completes. Eventually, it just locks up the machine
then returns out of memory. I have 2 GB of memory on the machine.

=20

WebTest is run from an Ant script which runs java on
org.apache.tools.ant.launch.Launcher, fork=3Dtrue, maxmemory=3D1024m.

=20

WebTest: build 1453

Ant: 1.6.5 (also tried 1.7.0)

=20

I am including the WebTest taskdef only once as was suggested in eariler
discussions. I am using the xml results output. Any ideas?

=20

Tim

=20

(This email message is for the sole use of the intended recipient(s) and
may contain confidential information.  Any unauthorized review, use,
disclosure or distribution is prohibited.  If you are not the intended
recipient, please contact the sender by reply email and destroy all
copies of the original message.)

=20


------_=_NextPart_001_01C781E0.5F9A2E78
Content-Type: text/html;
	charset="us-ascii"
Content-Transfer-Encoding: quoted-printable

<html xmlns:o=3D"urn:schemas-microsoft-com:office:office" =
xmlns:w=3D"urn:schemas-microsoft-com:office:word" =
xmlns=3D"http://www.w3.org/TR/REC-html40">

<head>
<meta http-equiv=3DContent-Type content=3D"text/html; =
charset=3Dus-ascii">
<meta name=3DGenerator content=3D"Microsoft Word 11 (filtered medium)">
<style>
<!--
 /* Style Definitions */
 p.MsoNormal, li.MsoNormal, div.MsoNormal
	{margin:0in;
	margin-bottom:.0001pt;
	font-size:12.0pt;
	font-family:"Times New Roman";}
a:link, span.MsoHyperlink
	{color:blue;
	text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
	{color:purple;
	text-decoration:underline;}
span.EmailStyle17
	{mso-style-type:personal-compose;
	font-family:Arial;
	color:windowtext;}
@page Section1
	{size:8.5in 11.0in;
	margin:1.0in 1.25in 1.0in 1.25in;}
div.Section1
	{page:Section1;}
-->
</style>

</head>

<body lang=3DEN-US link=3Dblue vlink=3Dpurple>

<div class=3DSection1>

<p class=3DMsoNormal><font size=3D2 face=3DArial><span =
style=3D'font-size:10.0pt;
font-family:Arial'>I have a project which contains 12 WebTests, each =
WebTest
contains approximately 50-60 steps. I can only run 4 of the WebTests at =
a time.
Anything more and I get an out of memory. Each WebTest seems to use =
about .1 GB
of memory when it runs, the memory usage never goes down once each =
WebTest
completes. Eventually, it just locks up the machine then returns out of =
memory.
I have 2 GB of memory on the machine.<o:p></o:p></span></font></p>

<p class=3DMsoNormal><font size=3D2 face=3DArial><span =
style=3D'font-size:10.0pt;
font-family:Arial'><o:p>&nbsp;</o:p></span></font></p>

<p class=3DMsoNormal><font size=3D2 face=3DArial><span =
style=3D'font-size:10.0pt;
font-family:Arial'>WebTest is run from an Ant script which runs java on =
org.apache.tools.ant.launch.Launcher,
fork=3Dtrue, maxmemory=3D1024m.<o:p></o:p></span></font></p>

<p class=3DMsoNormal><font size=3D2 color=3Dblack face=3DArial><span =
style=3D'font-size:
10.0pt;font-family:Arial;color:black'><o:p>&nbsp;</o:p></span></font></p>=


<p class=3DMsoNormal><font size=3D2 color=3Dblack face=3DArial><span =
style=3D'font-size:
10.0pt;font-family:Arial;color:black'>WebTest: build =
1453<o:p></o:p></span></font></p>

<p class=3DMsoNormal><font size=3D2 face=3DArial><span =
style=3D'font-size:10.0pt;
font-family:Arial'>Ant: 1.6.5 (also tried =
1.7.0)<o:p></o:p></span></font></p>

<p class=3DMsoNormal><font size=3D2 face=3DArial><span =
style=3D'font-size:10.0pt;
font-family:Arial'><o:p>&nbsp;</o:p></span></font></p>

<p class=3DMsoNormal><font size=3D2 face=3DArial><span =
style=3D'font-size:10.0pt;
font-family:Arial'>I am including the WebTest taskdef only once as was
suggested in eariler discussions. I am using the xml results output. Any =
ideas?<o:p></o:p></span></font></p>

<p class=3DMsoNormal><font size=3D2 face=3DArial><span =
style=3D'font-size:10.0pt;
font-family:Arial'><o:p>&nbsp;</o:p></span></font></p>

<p class=3DMsoNormal><font size=3D2 face=3DArial><span =
style=3D'font-size:10.0pt;
font-family:Arial'>Tim<o:p></o:p></span></font></p>

<p class=3DMsoNormal><font size=3D2 face=3DArial><span =
style=3D'font-size:10.0pt;
font-family:Arial'><o:p>&nbsp;</o:p></span></font></p>

<p class=3DMsoNormal><font size=3D1 face=3DArial><span =
style=3D'font-size:7.5pt;
font-family:Arial'>(This email message is for the sole use of the =
intended
recipient(s) and may contain confidential information.&nbsp; Any =
unauthorized
review, use, disclosure or distribution is prohibited.&nbsp; If you are =
not the
intended recipient, please contact the sender by reply email and destroy =
all
copies of the original message.)</span></font><o:p></o:p></p>

<p class=3DMsoNormal><font size=3D3 face=3D"Times New Roman"><span =
style=3D'font-size:
12.0pt'><o:p>&nbsp;</o:p></span></font></p>

</div>

</body>

</html>

------_=_NextPart_001_01C781E0.5F9A2E78--