[Webtest] Out of memory when running WebTest

Marc Guillemot Marc Guillemot <mguillemot@yahoo.fr>
Thu, 19 Apr 2007 17:28:22 +0200


Quite strange. I'm used to run test sequence more than 100 times bigger
than yours without problem.

Have you tried to profile WebTest to see where is the lost memory? Is JS
involved? PDF files? Excel files? Many windows?

Marc.

Tim Miller wrote:
> I have a project which contains 12 WebTests, each WebTest contains
> approximately 50-60 steps. I can only run 4 of the WebTests at a time.
> Anything more and I get an out of memory. Each WebTest seems to use
> about .1 GB of memory when it runs, the memory usage never goes down
> once each WebTest completes. Eventually, it just locks up the machine
> then returns out of memory. I have 2 GB of memory on the machine.
> 
>  
> 
> WebTest is run from an Ant script which runs java on
> org.apache.tools.ant.launch.Launcher, fork=true, maxmemory=1024m.
> 
>  
> 
> WebTest: build 1453
> 
> Ant: 1.6.5 (also tried 1.7.0)
> 
>  
> 
> I am including the WebTest taskdef only once as was suggested in eariler
> discussions. I am using the xml results output. Any ideas?
> 
>  
> 
> Tim
> 
>  
> 
> (This email message is for the sole use of the intended recipient(s) and
> may contain confidential information.  Any unauthorized review, use,
> disclosure or distribution is prohibited.  If you are not the intended
> recipient, please contact the sender by reply email and destroy all
> copies of the original message.)
> 
>  
>