[Webtest] Error org.apache.xerces.xni.XNIException

Moynihan, Michael A Moynihan, Michael A" <Michael.A.Moynihan@Fmr.com
Mon, 30 Apr 2007 15:04:08 -0400


This is a multi-part message in MIME format.

------_=_NextPart_001_01C78B5A.54CE0245
Content-Type: text/plain;
	charset="us-ascii"
Content-Transfer-Encoding: quoted-printable

Hi,

I'm using Canoo Webtest 2.0. When I try to kick off my canoo tests I get
the following error=20

 [testSpec] org.apache.xerces.xni.XNIException
 [testSpec]     at
org.cyberneko.html.HTMLScanner$ContentScanner.scan(HTMLScanne
r.java:1860)
 [testSpec]     at
org.cyberneko.html.HTMLScanner.scanDocument(HTMLScanner.java:
789)
 [testSpec]     at
org.cyberneko.html.HTMLConfiguration.parse(HTMLConfiguration.
java:478)
 [testSpec]     at
org.cyberneko.html.HTMLConfiguration.parse(HTMLConfiguration.
java:431)
 [testSpec]     at org.apache.xerces.parsers.XMLParser.parse(Unknown
Source)
 [testSpec]     at
com.gargoylesoftware.htmlunit.html.HTMLParser$HtmlUnitDOMBuil
der.parse(HTMLParser.java:330)
 [testSpec]     at
com.gargoylesoftware.htmlunit.html.HTMLParser.parse(HTMLParse

When it tries to parse an xml page.

My installation of canoo seems to be ok because when I run the
installation verifier

	ant -buildfile installText.xml from the doc/samples folder

the build is successful.=20

Does anyone know why I'm getting an xerces exception? I'm using JDK1.4
and the xml file that throws the error works fine for other colleagues
of mine. It must be a problem specific to my environment but can anyone
think what?

Thanking you in advance,

Michael





------_=_NextPart_001_01C78B5A.54CE0245
Content-Type: text/html;
	charset="us-ascii"
Content-Transfer-Encoding: quoted-printable

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//EN">
<HTML>
<HEAD>
<META HTTP-EQUIV=3D"Content-Type" CONTENT=3D"text/html; =
charset=3Dus-ascii">
<META NAME=3D"Generator" CONTENT=3D"MS Exchange Server version =
6.0.6619.9">
<TITLE>Error org.apache.xerces.xni.XNIException</TITLE>
</HEAD>
<BODY>
<!-- Converted from text/rtf format -->

<P><FONT SIZE=3D2 FACE=3D"Arial">Hi,</FONT>
</P>

<P><FONT SIZE=3D2 FACE=3D"Arial">I'm using Canoo Webtest 2.0. When I try =
to kick off my canoo tests I get the following error </FONT>
</P>

<P><FONT SIZE=3D2 FACE=3D"Arial">&nbsp;[testSpec] =
org.apache.xerces.xni.XNIException</FONT>

<BR><FONT SIZE=3D2 =
FACE=3D"Arial">&nbsp;[testSpec]&nbsp;&nbsp;&nbsp;&nbsp; at =
org.cyberneko.html.HTMLScanner$ContentScanner.scan(HTMLScanne</FONT>

<BR><FONT SIZE=3D2 FACE=3D"Arial">r.java:1860)</FONT>

<BR><FONT SIZE=3D2 =
FACE=3D"Arial">&nbsp;[testSpec]&nbsp;&nbsp;&nbsp;&nbsp; at =
org.cyberneko.html.HTMLScanner.scanDocument(HTMLScanner.java:</FONT>

<BR><FONT SIZE=3D2 FACE=3D"Arial">789)</FONT>

<BR><FONT SIZE=3D2 =
FACE=3D"Arial">&nbsp;[testSpec]&nbsp;&nbsp;&nbsp;&nbsp; at =
org.cyberneko.html.HTMLConfiguration.parse(HTMLConfiguration.</FONT>

<BR><FONT SIZE=3D2 FACE=3D"Arial">java:478)</FONT>

<BR><FONT SIZE=3D2 =
FACE=3D"Arial">&nbsp;[testSpec]&nbsp;&nbsp;&nbsp;&nbsp; at =
org.cyberneko.html.HTMLConfiguration.parse(HTMLConfiguration.</FONT>

<BR><FONT SIZE=3D2 FACE=3D"Arial">java:431)</FONT>

<BR><FONT SIZE=3D2 =
FACE=3D"Arial">&nbsp;[testSpec]&nbsp;&nbsp;&nbsp;&nbsp; at =
org.apache.xerces.parsers.XMLParser.parse(Unknown Source)</FONT>

<BR><FONT SIZE=3D2 =
FACE=3D"Arial">&nbsp;[testSpec]&nbsp;&nbsp;&nbsp;&nbsp; at =
com.gargoylesoftware.htmlunit.html.HTMLParser$HtmlUnitDOMBuil</FONT>

<BR><FONT SIZE=3D2 FACE=3D"Arial">der.parse(HTMLParser.java:330)</FONT>

<BR><FONT SIZE=3D2 =
FACE=3D"Arial">&nbsp;[testSpec]&nbsp;&nbsp;&nbsp;&nbsp; at =
com.gargoylesoftware.htmlunit.html.HTMLParser.parse(HTMLParse</FONT>
</P>

<P><FONT SIZE=3D2 FACE=3D"Arial">When it tries to parse an xml =
page.</FONT>
</P>

<P><FONT SIZE=3D2 FACE=3D"Arial">My installation of canoo seems to be ok =
because when I run the installation verifier</FONT>
</P>

<P>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; <FONT SIZE=3D2 =
FACE=3D"Arial">ant -buildfile installText.xml from the doc/samples =
folder</FONT>
</P>

<P><FONT SIZE=3D2 FACE=3D"Arial">the build is successful. </FONT>
</P>

<P><FONT SIZE=3D2 FACE=3D"Arial">Does anyone know why I'm getting an =
xerces exception? I'm using JDK1.4 and the xml file that throws the =
error works fine for other colleagues of mine. It must be a problem =
specific to my environment but can anyone think what?</FONT></P>

<P><FONT SIZE=3D2 FACE=3D"Arial">Thanking you in advance,</FONT>
</P>

<P><FONT SIZE=3D2 FACE=3D"Arial">Michael</FONT>
</P>
<BR>
<BR>
<BR>

</BODY>
</HTML>
------_=_NextPart_001_01C78B5A.54CE0245--