[Webtest] [webtest][JIRA] Created: (WT-301) setCheckbox doesn't work with htmlId

Juergen Zimmermann (JIRA) Juergen Zimmermann (JIRA)" <noreply@canoo.com
Thu, 3 May 2007 11:08:53 +0200 (CEST)


setCheckbox doesn't work with htmlId
------------------------------------

         Key: WT-301
         URL: http://webtest-community.canoo.com/jira/browse/WT-301
     Project: WebTest
        Type: Bug

    Versions: 2.5    
 Environment: WebTest R_1550, WinXP SP2, JBoss 4.2.0CR2 with JSF RI 1.2_04 P01
    Reporter: Juergen Zimmermann


In build.xml I have these steps:
<selectForm description="..." name="deleteForm"/>
<setCheckbox description="..." htmlId="kundenTabelle:1" value="1"/>

The HTML page was generated via JSF RI and looks as follows:

<form id="deleteForm" name="deleteForm" method="post" action="/hska/faces/kundenverwaltung/checkboxDelete.jsp" enctype="application/x-www-form-urlencoded">
<input type="hidden" name="deleteForm" value="deleteForm" />
<table id="kundenTabelle">
	<tr>
<td>
<input name="kundenTabelle" id="kundenTabelle:0" value="0" type="checkbox" /><label for="kundenTabelle:0"> 21: N&uuml;, Nb</label></td>
	</tr>
	<tr>
<td>
<input name="kundenTabelle" id="kundenTabelle:1" value="1" type="checkbox" /><label for="kundenTabelle:1"> 26: N&uuml;, Ng</label></td>
	</tr>
...

However, WebTest R_1550 yields this error message:
Found input when looking for checkbox

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://webtest-community.canoo.com/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira