[Webtest] dbUnit Integration/Failure

Goldberger, Michael Goldberger, Michael" <mgoldberger@otn.ca
Tue, 5 Jun 2007 11:16:33 -0400


This is a multi-part message in MIME format.


------_=_NextPart_001_01C7A784.8082BAB4
Content-Type: text/plain;
	charset="us-ascii"
Content-Transfer-Encoding: quoted-printable

Hi all,=0D=0A=0D=0A =0D=0A=0D=0AWe have been attempting to integrate dbUnit=
 into our test framework and=0D=0AI have run across a problem=2E The task i=
tself runs fine (normally),=0D=0Ahowever when the dbUnit step fails inside =
a webtest, the entire ant=0D=0Abuild fails=2E We also use cruisecontrol for=
 continuous integration builds=0D=0Aevery night and having a build fail com=
pletely due to one step inside=0D=0Aone test (quite a large suite) is compl=
etely unacceptable for our=0D=0Apurposes=2E=0D=0A=0D=0A =0D=0A=0D=0AMy ques=
tion to all then is, is there any way to more closely integrate=0D=0AdbUnit=
 into WebTest or any way to force the build to continue upon a=0D=0AdbUnit =
step failing?=0D=0A=0D=0A =0D=0A=0D=0AThanks for your help,=0D=0A=0D=0A =0D=
=0A=0D=0AMike=0D=0A=0D=0A=0D=0A=0D=0AThe information contained in this emai=
l and document(s) attached=0Aare for the exclusive use of the addressee and=
 may contain=0Aconfidential information=2E If the recipient of this e-mail =
is not=0Athe addressee, such recipient is strictly prohibited from reading,=
=0Aphotocopying, distributing or otherwise using this e-mail or its=0Aconte=
nt in any way=2E
------_=_NextPart_001_01C7A784.8082BAB4
Content-Type: text/html;
	charset="us-ascii"
Content-Transfer-Encoding: quoted-printable

<html xmlns:o=3D"urn:schemas-microsoft-com:office:office" xmlns:w=3D"urn:sc=
hemas-microsoft-com:office:word" xmlns=3D"http://www=2Ew3=2Eorg/TR/REC-html=
40">=0D=0A=0D=0A<head>=0D=0A<META HTTP-EQUIV=3D"Content-Type" CONTENT=3D"te=
xt/html; charset=3Dus-ascii">=0D=0A<meta name=3DGenerator content=3D"Micros=
oft Word 11 (filtered medium)">=0D=0A<style>=0D=0A<!--=0D=0A /* Style Defin=
itions */=0D=0A p=2EMsoNormal, li=2EMsoNormal, div=2EMsoNormal=0D=0A	{margi=
n:0cm;=0D=0A	margin-bottom:=2E0001pt;=0D=0A	font-size:12=2E0pt;=0D=0A	font-=
family:"Times New Roman";}=0D=0Aa:link, span=2EMsoHyperlink=0D=0A	{color:bl=
ue;=0D=0A	text-decoration:underline;}=0D=0Aa:visited, span=2EMsoHyperlinkFo=
llowed=0D=0A	{color:purple;=0D=0A	text-decoration:underline;}=0D=0Aspan=2EE=
mailStyle17=0D=0A	{mso-style-type:personal-compose;=0D=0A	font-family:Arial=
;=0D=0A	color:windowtext;}=0D=0A@page Section1=0D=0A	{size:612=2E0pt 792=2E=
0pt;=0D=0A	margin:72=2E0pt 90=2E0pt 72=2E0pt 90=2E0pt;}=0D=0Adiv=2ESection1=
=0D=0A	{page:Section1;}=0D=0A-->=0D=0A</style>=0D=0A=0D=0A</head>=0D=0A=0D=
=0A<body lang=3DEN-US link=3Dblue vlink=3Dpurple>=0D=0A=0D=0A<div class=3DS=
ection1>=0D=0A=0D=0A<p class=3DMsoNormal><font size=3D2 face=3DArial><span =
style=3D'font-size:10=2E0pt;=0D=0Afont-family:Arial'>Hi all,<o:p></o:p></sp=
an></font></p>=0D=0A=0D=0A<p class=3DMsoNormal><font size=3D2 face=3DArial>=
<span style=3D'font-size:10=2E0pt;=0D=0Afont-family:Arial'><o:p>&nbsp;</o:p=
></span></font></p>=0D=0A=0D=0A<p class=3DMsoNormal><font size=3D2 face=3DA=
rial><span style=3D'font-size:10=2E0pt;=0D=0Afont-family:Arial'>We have bee=
n attempting to integrate dbUnit into our test=0D=0Aframework and I have ru=
n across a problem=2E The task itself runs fine=0D=0A(normally), however wh=
en the dbUnit step fails inside a webtest, the entire ant=0D=0Abuild fails=
=2E We also use cruisecontrol for continuous integration builds every=0D=0A=
night and having a build fail completely due to one step inside one test (q=
uite=0D=0Aa large suite) is completely unacceptable for our purposes=2E<o:p=
></o:p></span></font></p>=0D=0A=0D=0A<p class=3DMsoNormal><font size=3D2 fa=
ce=3DArial><span style=3D'font-size:10=2E0pt;=0D=0Afont-family:Arial'><o:p>=
&nbsp;</o:p></span></font></p>=0D=0A=0D=0A<p class=3DMsoNormal><font size=
=3D2 face=3DArial><span style=3D'font-size:10=2E0pt;=0D=0Afont-family:Arial=
'>My question to all then is, is there any way to more closely=0D=0Aintegra=
te dbUnit into WebTest or any way to force the build to continue upon a=0D=
=0AdbUnit step failing?<o:p></o:p></span></font></p>=0D=0A=0D=0A<p class=3D=
MsoNormal><font size=3D2 face=3DArial><span style=3D'font-size:10=2E0pt;=0D=
=0Afont-family:Arial'><o:p>&nbsp;</o:p></span></font></p>=0D=0A=0D=0A<p cla=
ss=3DMsoNormal><font size=3D2 face=3DArial><span style=3D'font-size:10=2E0p=
t;=0D=0Afont-family:Arial'>Thanks for your help,<o:p></o:p></span></font></=
p>=0D=0A=0D=0A<p class=3DMsoNormal><font size=3D2 face=3DArial><span style=
=3D'font-size:10=2E0pt;=0D=0Afont-family:Arial'><o:p>&nbsp;</o:p></span></f=
ont></p>=0D=0A=0D=0A<p class=3DMsoNormal><font size=3D2 face=3DArial><span =
style=3D'font-size:10=2E0pt;=0D=0Afont-family:Arial'>Mike<o:p></o:p></span>=
</font></p>=0D=0A=0D=0A</div>=0D=0A=0D=0A</body>=0D=0A=0D=0A</html>=0D=0A=
=0D=0A<HTML><BODY><P><hr size=3D1></P>=0D=0A<P><STRONG>=0D=0AThe informatio=
n contained in this email and document(s) attached are for the exclusive us=
e of the addressee and may contain confidential information=2E If the recip=
ient of this e-mail is not the addressee, such recipient is strictly prohib=
ited from reading, photocopying, distributing or otherwise using this e-mai=
l or its content in any way=2E=0D=0A=0D=0A</STRONG></P></BODY></HTML>
------_=_NextPart_001_01C7A784.8082BAB4--