[Webtest] classpath issue

Marc Guillemot Marc Guillemot <mguillemot@yahoo.fr>
Tue, 08 Jul 2008 11:55:35 +0200


Hi Lisa,

this seems to be the same problem than what Paul Beck reports. Perhaps a
strange java setup on Mac?

Cheers,
Marc.
-- 
Blog: http://mguillem.wordpress.com


Lisa Crispin wrote:
> Hi,
> 
> I run build 1710 with no problems on both Windows and Linux. I had run
> an earlier version on my mac with no problems, but only recently tried
> the new version there. I have a classpath issue, I get an error
> java.lang.NoSuchMethodError:
> org.apache.xpath.compiler.FunctionTale.installFunction(Ljava/lang/String;Ljava/lang/Class:).
> 
> 
> One of my colleagues helped me try to debug it. If we move
> xalan-2.7.0.jar from the webtest lib directory to ant's lib directory,
> then it works, it seems to be able to find everything else.
> 
> Can anyone tell me how I might debug this further to find out why it
> can't find the xalan jar file normally? I set the webtesthome property
> in the ant command line. I read on the list that if you use webtest.sh
> instead of ant to run, you can avoid classpath issues, but I don't have
> the time right now to figure out how to go about doing this (especially
> since the same version of WebTest runs fine on three other machines).
> I'm just out of ideas how to debug it.
> 
> Thanks,
> Lisa