[Webtest] Problem with ajax content update

Steve Chikwaya Steve Chikwaya" <stavarotti@gmail.com
Thu, 10 Jul 2008 16:19:54 -0500


------=_Part_30946_2336964.1215724794581
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

Hi everyone,

Our intranet homepage has ajax content that loads independent of other
elements on the page.  The initial display is that of a string "Loading.."
after which the ajax content is retrieved and displayed.  Since there is no
page refresh, webtest captures the "Loading..." string and sticks with that
until a link is clicked, essentially voiding any type of text or link
verification associated with the ajax content.  Is there anyway that I can
perform the tests after the whole page, including the ajax content, has
loaded without having to navigate around the page for fresh page hits?

Thanks,


-STeve Chikwaya.

------=_Part_30946_2336964.1215724794581
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

Hi everyone,<br><br>Our intranet homepage has ajax content that loads independent of other elements on the page.&nbsp; The initial display is that of a string &quot;Loading..&quot; after which the ajax content is retrieved and displayed.&nbsp; Since there is no page refresh, webtest captures the &quot;Loading...&quot; string and sticks with that until a link is clicked, essentially voiding any type of text or link verification associated with the ajax content.&nbsp; Is there anyway that I can perform the tests after the whole page, including the ajax content, has loaded without having to navigate around the page for fresh page hits?<br>
<br>Thanks,<br><br><br>-STeve Chikwaya.<br>

------=_Part_30946_2336964.1215724794581--