[Webtest] Problem with ajax content update

Soula, William Soula, William" <wsoula@pointserve.com
Fri, 11 Jul 2008 06:56:10 -0500


--_000_93B3B6122B906D44BC7E8B8CEFB0DBBB1844F45C5DSGPEXCHANGEpo_
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: quoted-printable

see if this thread helps: http://www.nabble.com/WebTest-fails-on-Petstore-2=
.0-to18298183.html#a18298183

________________________________
From: webtest-admin@lists.canoo.com [mailto:webtest-admin@lists.canoo.com] =
On Behalf Of Steve Chikwaya
Sent: Thursday, July 10, 2008 4:20 PM
To: webtest@lists.canoo.com
Subject: [Webtest] Problem with ajax content update

Hi everyone,

Our intranet homepage has ajax content that loads independent of other elem=
ents on the page.  The initial display is that of a string "Loading.." afte=
r which the ajax content is retrieved and displayed.  Since there is no pag=
e refresh, webtest captures the "Loading..." string and sticks with that un=
til a link is clicked, essentially voiding any type of text or link verific=
ation associated with the ajax content.  Is there anyway that I can perform=
 the tests after the whole page, including the ajax content, has loaded wit=
hout having to navigate around the page for fresh page hits?

Thanks,


-STeve Chikwaya.

--_000_93B3B6122B906D44BC7E8B8CEFB0DBBB1844F45C5DSGPEXCHANGEpo_
Content-Type: text/html; charset="us-ascii"
Content-Transfer-Encoding: quoted-printable

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META http-equiv=3DContent-Type content=3D"text/html; charset=3Dus-ascii">
<META content=3D"MSHTML 6.00.6000.16674" name=3DGENERATOR></HEAD>
<BODY>
<DIV dir=3Dltr align=3Dleft><SPAN class=3D729135411-11072008><FONT face=3DA=
rial=20
color=3D#0000ff size=3D2>see if this thread helps: <A=20
href=3D"http://www.nabble.com/WebTest-fails-on-Petstore-2.0-to18298183.html=
#a18298183">http://www.nabble.com/WebTest-fails-on-Petstore-2.0-to18298183.=
html#a18298183</A></FONT></SPAN></DIV><BR>
<DIV class=3DOutlookMessageHeader lang=3Den-us dir=3Dltr align=3Dleft>
<HR tabIndex=3D-1>
<FONT face=3DTahoma size=3D2><B>From:</B> webtest-admin@lists.canoo.com=20
[mailto:webtest-admin@lists.canoo.com] <B>On Behalf Of </B>Steve=20
Chikwaya<BR><B>Sent:</B> Thursday, July 10, 2008 4:20 PM<BR><B>To:</B>=20
webtest@lists.canoo.com<BR><B>Subject:</B> [Webtest] Problem with ajax cont=
ent=20
update<BR></FONT><BR></DIV>
<DIV></DIV>Hi everyone,<BR><BR>Our intranet homepage has ajax content that =
loads=20
independent of other elements on the page.&nbsp; The initial display is tha=
t of=20
a string "Loading.." after which the ajax content is retrieved and=20
displayed.&nbsp; Since there is no page refresh, webtest captures the=20
"Loading..." string and sticks with that until a link is clicked, essential=
ly=20
voiding any type of text or link verification associated with the ajax=20
content.&nbsp; Is there anyway that I can perform the tests after the whole=
=20
page, including the ajax content, has loaded without having to navigate aro=
und=20
the page for fresh page hits?<BR><BR>Thanks,<BR><BR><BR>-STeve=20
Chikwaya.<BR></BODY></HTML>

--_000_93B3B6122B906D44BC7E8B8CEFB0DBBB1844F45C5DSGPEXCHANGEpo_--