[Webtest] Trunk build fails on MacBook Pro Leopard

Paul Beck Paul Beck" <pbeck@nearinfinity.com
Mon, 14 Jul 2008 20:57:41 -0400


Denis,

Hi. I am building with Java 5. I got it to build by placing the
xalan-2.7.0.jar file in /Library/Java/Extensions. I looked on all the
paths you listed, and I believe that xalan.jar (no version specified)
was in one of them. I deleted it several weeks ago when I put the
2.7.0 version in Extensions, and I don't remember which directory it
was in. At any rate, it almost completes the build now, stopping with
the following error.

BUILD FAILED
/Users/pbeck/workspace/webtest/build.xml:1022: The following error
occurred while executing this line:
/Users/pbeck/workspace/webtest/build.xml:1178: The following error
occurred while executing this line:
/Users/pbeck/workspace/webtest/build.xml:741: Warning: Could not find
file /Users/pbeck/workspace/webtest/build/releasetests/reports/WebTestOverview.xml
to copy

By this time, it has built all the necessary zip files for deployment,
so I have not worried about that error.

Have you tried WebTest with AJAX output? Did you see my post about WT
looping? Nobody has answered it, yet I must believe that others have
seen this behavior, as it is completely repeatable for me. It happens
when I put a <sleep> before the <verifyText> or use the recommended
"easyAjax" config parameter.

Paul

On Thu, Jul 10, 2008 at 12:53 AM, Denis N. Antonioli
<antonioli@ifi.unizh.ch> wrote:
> Hi
> I just followed the instruction on a plain Mac (10.5.2, java 5), and it
> worked fine, as expected ;-)
> @Paul:
> Are you building with java 5 or 6?
> Is there a xalan in java's extension directories
> (/System/Library/Frameworks/JavaVM.framework/Versions/1.5/Home/lib, /System/Library/Frameworks/JavaVM.framework/Versions/1.5/Home/lib/ext, /System/Library/Frameworks/JavaVM.framework/Versions/1.5/Home/lib/endorsed, /System/Library/Frameworks/JavaVM.framework/Versions/1.6/Home/lib, /System/Library/Frameworks/JavaVM.framework/Versions/1.6/Home/lib/ext, /System/Library/Frameworks/JavaVM.framework/Versions/1.6/Home/lib/endorsed)
> Is there a xalan on your $CLASSPATH?
> @Lisa:
> Which ant are you using?
> There is a $WEBTEST_HOME/bin/webtest.sh precisely to be certain that the
> correct versions of the libraries are used  ;-)
>
> Happy testing
> dna
>
>
> On 8 juil. 08, at 09:03, Lisa Crispin wrote:
>
> Paul, I'm having this same problem when I try to run a WebTest script on my
> Mac. I didn't have it with an older version of WebTest. When I move that
> xalan jar file to ant's lib directory, it works.
>
> I've run out of ideas, so if you are able to fix this on your mac, please
> let me know what you did!
> thanks
> Lisa
>
> On Sat, Jul 5, 2008 at 10:03 PM, Paul Beck <pbeck@nearinfinity.com> wrote:
>>
>> I am attempting a build of WebTest on a MB Pro with 2Gb memory and Java 5
>> installed. I am getting the following build errors, building on command
>> line
>> or within IntelliJ.
>>
>> -compile:
>>     [echo] compile base classes
>>    [javac] Compiling 216 source files to
>> /Users/pbeck/workspace/webtest/build/classes/plain
>>    [javac]
>>
>> /Users/pbeck/workspace/webtest/src/main/java/com/canoo/webtest/engine/xpath/
>> SimpleXPathFunctionResolver.java:31: cannot find symbol
>>    [javac] symbol  : method
>> installFunction(java.lang.String,java.lang.Class<capture of ? extends
>> org.apache.xpath.functions.Function>)
>>    [javac] location: class org.apache.xpath.compiler.FunctionTable
>>    [javac]
>> funcTable_.installFunction(_functionName.getLocalPart(),
>> _class);
>>    [javac]                   ^
>>    [javac]
>>
>> /Users/pbeck/workspace/webtest/src/main/java/com/canoo/webtest/engine/xpath/
>> XPathHelper.java:328: cannot find symbol
>>    [javac] symbol  : constructor
>>
>> XPath(java.lang.String,<nulltype>,com.canoo.webtest.engine.xpath.PrefixResol
>> ver,int,<nulltype>,org.apache.xpath.compiler.FunctionTable)
>>    [javac] location: class org.apache.xpath.XPath
>>    [javac]             org.apache.xpath.XPath xpath = new
>> org.apache.xpath.XPath(expression, null,
>>    [javac]                                                ^
>>    [javac] Note: Some input files use or override a deprecated API.
>>    [javac] Note: Recompile with -Xlint:deprecation for details.
>>    [javac] Note: Some input files use unchecked or unsafe operations.
>>    [javac] Note: Recompile with -Xlint:unchecked for details.
>>    [javac] 2 errors
>>
>> I looked in xalan-2.7.0-src.jar, and found the supposed undefined method
>> installFunction. So, do I have a classpath issue somehow? I am building
>> with
>> webtest clean develop as per the instructions. I followed the instructions
>> on the website for building, checking out from svn in WEBTEST_HOME. The
>> instructions imply that you can do the build from WEBTEST_HOME, however
>> the
>> build file is checked out from the repository into the webtest
>> subdirectory.
>> Unless I am doing something wrong, the instructions do not work as
>> written:
>>
>> To generate a complete release, including the documentation, type:
>> cd <WEBTEST_HOME>
>> bin/webtest.sh full
>>
>> Can someone please help with this build?
>>
>> Paul Beck
>>
>>
>> _______________________________________________
>> WebTest mailing list
>> WebTest@lists.canoo.com
>> http://lists.canoo.com/mailman/listinfo/webtest
>
>
>
> --
> Lisa Crispin
> Co-author with Janet Gregory, Agile Testing
> http://www.agiletester.ca
> http://lisa.crispin.home.att.net
> http://lisacrispin.blogspot.com
>
> --
> If you understand what you're doing, you're not learning anything.
>   -- Abraham Lincoln
>
>