[Webtest] basic ajax test

Andrea Casalicchio Andrea Casalicchio <andrea_2gi@hotmail.com>
Tue, 22 Jul 2008 18:12:39 +0200


--_7e49c1a0-280d-4983-96e2-8d7d5148e36d_
Content-Type: text/plain; charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable


It works!i give the focus using the clickElement step with xpath.
Thanks a lot.
=20
Andrea
=20
=20
> From: mguillemot@yahoo.fr> To: webtest@lists.canoo.com> Subject: Re: [Web=
test] basic ajax test> Date: Mon=2C 21 Jul 2008 15:07:24 +0200> > Hi=2C> > =
my guess is that WebTest is simply to fast here. First to be sure that> you=
r AJAX librarie(s) are supported=2C you can add a <sleep seconds=3D"5"/>> f=
or instance after setting the focus to a field (how do you do it btw?).> Th=
is can be optimized later.> > Cheers=2C> Marc.> -- > Blog: http://mguillem.=
wordpress.com> > > Andrea Casalicchio wrote:> > Hello everyone=2C> > I'm a =
newbie in webtest and I'm trying to create a test suite for my> > ajax func=
tions=2C but i'm experiencing a big problem.> > I've got a simple form with=
 tooltip loaded trough ajax in a cell at the> > right of each field: when y=
ou give focus to the form field ajax gets the> > tooltip from mysql and fil=
ls the table cell with a string.> > using webtest i can connect to the page=
=2C check its title=2C use> > clickElement to click the first field in the =
list=2C but when i try to> > verify that the cell content has been updated =
i always find it empty.> > I've tried lots of different steps reaching the =
cell content with xpath> > but the content never gets updated=2C what shoul=
d i do? i'm making some> > mistake in my assumption? is there any step that=
 i should use to> > accomplish this task?> > thanks in forward=2C have a ni=
ce day.> > > > Andrea> > > > ----------------------------------------------=
--------------------------> > Windows Live Messenger Firma le tue e-mail co=
n Messenger!> > <http://www.messenger.it/Messenger/Button/Default.aspx>> > =
_______________________________________________> WebTest mailing list> WebT=
est@lists.canoo.com> http://lists.canoo.com/mailman/listinfo/webtest
_________________________________________________________________
Curiosit=E0=2C trucchi e consigli per il tuo Messenger!
http://www.messenger.it=

--_7e49c1a0-280d-4983-96e2-8d7d5148e36d_
Content-Type: text/html; charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

<html>
<head>
<style>
.hmmessage P
{
margin:0px=3B
padding:0px
}
body.hmmessage
{
FONT-SIZE: 10pt=3B
FONT-FAMILY:Tahoma
}
</style>
</head>
<body class=3D'hmmessage'>
It works!<BR>i give the focus using the clickElement step with xpath.<BR>
Thanks a lot.<BR>
&nbsp=3B<BR>
Andrea<BR>
&nbsp=3B<BR>
&nbsp=3B<BR>
<BR>&gt=3B From: mguillemot@yahoo.fr<BR>&gt=3B To: webtest@lists.canoo.com<=
BR>&gt=3B Subject: Re: [Webtest] basic ajax test<BR>&gt=3B Date: Mon=2C 21 =
Jul 2008 15:07:24 +0200<BR>&gt=3B <BR>&gt=3B Hi=2C<BR>&gt=3B <BR>&gt=3B my =
guess is that WebTest is simply to fast here. First to be sure that<BR>&gt=
=3B your AJAX librarie(s) are supported=2C you can add a &lt=3Bsleep second=
s=3D"5"/&gt=3B<BR>&gt=3B for instance after setting the focus to a field (h=
ow do you do it btw?).<BR>&gt=3B This can be optimized later.<BR>&gt=3B <BR=
>&gt=3B Cheers=2C<BR>&gt=3B Marc.<BR>&gt=3B -- <BR>&gt=3B Blog: http://mgui=
llem.wordpress.com<BR>&gt=3B <BR>&gt=3B <BR>&gt=3B Andrea Casalicchio wrote=
:<BR>&gt=3B &gt=3B Hello everyone=2C<BR>&gt=3B &gt=3B I'm a newbie in webte=
st and I'm trying to create a test suite for my<BR>&gt=3B &gt=3B ajax funct=
ions=2C but i'm experiencing a big problem.<BR>&gt=3B &gt=3B I've got a sim=
ple form with tooltip loaded trough ajax in a cell at the<BR>&gt=3B &gt=3B =
right of each field: when you give focus to the form field ajax gets the<BR=
>&gt=3B &gt=3B tooltip from mysql and fills the table cell with a string.<B=
R>&gt=3B &gt=3B using webtest i can connect to the page=2C check its title=
=2C use<BR>&gt=3B &gt=3B clickElement to click the first field in the list=
=2C but when i try to<BR>&gt=3B &gt=3B verify that the cell content has bee=
n updated i always find it empty.<BR>&gt=3B &gt=3B I've tried lots of diffe=
rent steps reaching the cell content with xpath<BR>&gt=3B &gt=3B but the co=
ntent never gets updated=2C what should i do? i'm making some<BR>&gt=3B &gt=
=3B mistake in my assumption? is there any step that i should use to<BR>&gt=
=3B &gt=3B accomplish this task?<BR>&gt=3B &gt=3B thanks in forward=2C have=
 a nice day.<BR>&gt=3B &gt=3B <BR>&gt=3B &gt=3B Andrea<BR>&gt=3B &gt=3B <BR=
>&gt=3B &gt=3B ------------------------------------------------------------=
------------<BR>&gt=3B &gt=3B Windows Live Messenger Firma le tue e-mail co=
n Messenger!<BR>&gt=3B &gt=3B &lt=3Bhttp://www.messenger.it/Messenger/Butto=
n/Default.aspx&gt=3B<BR>&gt=3B <BR>&gt=3B _________________________________=
______________<BR>&gt=3B WebTest mailing list<BR>&gt=3B WebTest@lists.canoo=
.com<BR>&gt=3B http://lists.canoo.com/mailman/listinfo/webtest<BR><BR><br /=
><hr />Doretta <a href=3D'http://doretta82live.spaces.live.com/' target=3D'=
_new'>Doretta ti "cerca"! Vieni a trovarla sul suo Spaces!</a></body>
</html>=

--_7e49c1a0-280d-4983-96e2-8d7d5148e36d_--