[Webtest] [webtest][JIRA] Closed: (WT-456) Frames not opening on Webtest generated html page

Marc Guillemot (JIRA) Marc Guillemot (JIRA)" <noreply@canoo.com
Thu, 21 Aug 2008 09:11:19 +0200 (CEST)


     [ http://webtest-community.canoo.com/jira/browse/WT-456?page=all ]
     
Marc Guillemot closed WT-456:
-----------------------------

    Resolution: Invalid
     Assign To: Marc Guillemot

WebTest saves the pages received from the server, not the related resources and therefore no images. Concerning a frameset, if index.html contains a frameset, WebTest will save it as result of invoke for instance but it won't save the contained frame as this couldn't be displayed without modifying the code of the received response what WebTest NEVER does to allow you to see exactly what the server sent. Nevertheless once you use for instance a <followFrame/> the selected frame will become the current response and will be displayed in the report.

> Frames not opening on Webtest generated html page
> -------------------------------------------------
>
>          Key: WT-456
>          URL: http://webtest-community.canoo.com/jira/browse/WT-456
>      Project: WebTest
>         Type: Bug

>     Versions: 2.6
>  Environment: windows xp professional 2002, SP2
>     Reporter: rsvelavan
>     Assignee: Marc Guillemot
>  Attachments: 1.JPG
>
> Im new to this Web test , Can you please guide me from the following scenario i tried
> Scenario:
> 1. Installed the Canoo Web test 2.6 
> 2. Installed Ant 1.7
> 3. Here is my script : 
> - <project name="SimpleTest" basedir="." default="wt.full">
>   <property name="canoo" location="D:/canoo/webtest" /> 
>   <import file="${canoo}/webtest.xml" /> 
> - <target name="wt.testInWork">
> - <webtest name="my simple Test">
>   <invoke url="http://www.gmail.com/" description="get Login Page" /> 
>   <verifyTitle text="Gmail: Email from Google" description="we should see the login title" /> 
>   <img src=" placed the image path here "/>
>   <saveCurrentResponse images="true"/>  
>  <setinputfield stepid="set loginname" name="ltmpl" value="sample" /> 
>   <setinputfield stepid="set password" name="Passwd" value="sample" /> 
>   <clickbutton stepid="press signin button" name="signIn" /> 
>   </webtest>
>   </target>
>   </project>
> for the above  scenario , I dont see Images getting displayed on the html page which is generated by webtest.
> Then other scenario I tried with my project application, in that my application has frames on the html pages
> when i run the script in webtest , it executes all the steps and generating the html page through webtest but Im seeing "Page cannot be displayed" message in all of the frames. 
> Please refer screenshot for your reference.  
> can you please have a look at this and guide me on what i need to do further..?
> thanks 
> rsvelavan

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://webtest-community.canoo.com/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira