[Webtest] ActiveXObject Error

Marc Guillemot Marc Guillemot <mguillemot@yahoo.fr>
Fri, 22 Aug 2008 09:55:55 +0200


Hi,

are you sure that it works in your IE? "Mxsml2.XMLHTTP.3.0" is
misspelled, it should be "Msxml2.XMLHTTP.3.0": HtmlUnit able to catch
errors with ActiveX! ;-)

Cheers,
Marc.
-- 
Blog: http://mguillem.wordpress.com


Steve Chikwaya wrote:
> Hi all,
> 
> I am getting the following error when trying to run a webtest on an
> internal site:
> 
> [clickLink] ERROR
> (com.gargoylesoftware.htmlunit.javascript.JavaScriptEngine) -
> runtimeError: message=[ActiveXObject Error: no value for
> Mxsml2.XMLHTTP.3.0.]
> sourceName=[http://testserver/ScriptResource.axd?d=Q16yBbCVe2h9KDJ86qUi2PhkotP0xXinBhXErlIeswUtnsF9zzKwOPiAtJmYAW8WkuVZLCw-JJBEHZCTXaZtpOWTnuu6MG53FW83hLuNudY1&t=633414783035203188
> <http://testserver/ScriptResource.axd?d=Q16yBbCVe2h9KDJ86qUi2PhkotP0xXinBhXErlIeswUtnsF9zzKwOPiAtJmYAW8WkuVZLCw-JJBEHZCTXaZtpOWTnuu6MG53FW83hLuNudY1&t=633414783035203188>]
> line=[5] lineSource=[null] lineOffset=[0]
> 
> My webtest is as follows:
> 
> <webtest name="Create New Client" >
> 
>                <invoke url="http://testserver"/>
>             <verifyText text="Test Server System" />
>             <setInputField name="ctl00$PageBody$TextBoxUserName"
> value="test"/>
>             <setInputField name="ctl00$PageBody$TextBoxPassword"
> value="test1"/>
>             <clickLink description="click link to log in" label="submit"  />
>                 <verifyTitle description="Client Search must be present"
> text="Client Search" />
>                
>                 <!--======== Search for Client
> =================================-->
>                *<clickLink description="Go to Client Home" label="Test
> Client"/>*
>                <setInputField description="search for client"
> name="ctl00$PageBody$textBoxClientSearch" value=Test Site"/>
>                 <clickButton description="submit search"
> name="ctl00$PageBody$buttonSearch" />
>                 <verifyText description="Test server text must be
> present" text="TEST_SERVER" />
> 
> The link I am trying to click on is a javascript rgenerated link (Test
> Client) and hence my problem.  I tried to use an xpath expression,
> clickelement, and clicklink, with no success.  Any thoughts?
> 
> - Steve C      
> 
> -- 
> I'm not the person your mother warned you about... her imagination isn't
> that good!