[Webtest] ActiveXObject Error

Steve Chikwaya Steve Chikwaya" <stavarotti@gmail.com
Fri, 22 Aug 2008 10:05:57 -0500


------=_Part_45834_5972842.1219417557161
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

Hi Marc,

Yes, this does work in IE.  I checked the error console and this error does
not come up in either ie or firefox.  Mxsml2.XMLHTTP.3.0 only appears
spelled that way in the webtest exception stack trace.  Clicking on the link
in both firefox and ie on windows/linux works hence my concern that this
maybe an error in the manner in which I have written the test.  The xpath to
the link works with verfiyXpath and the correct values are passed into the
javascript function.  Is there anyway to disable activexerrors and continue
with the test or do you have any other suggestions?

Thanks.


On Fri, Aug 22, 2008 at 2:55 AM, Marc Guillemot <mguillemot@yahoo.fr> wrote:

> Hi,
>
> are you sure that it works in your IE? "Mxsml2.XMLHTTP.3.0" is
> misspelled, it should be "Msxml2.XMLHTTP.3.0": HtmlUnit able to catch
> errors with ActiveX! ;-)
>
> Cheers,
> Marc.
> --
> Blog: http://mguillem.wordpress.com
>
>
> Steve Chikwaya wrote:
> > Hi all,
> >
> > I am getting the following error when trying to run a webtest on an
> > internal site:
> >
> > [clickLink] ERROR
> > (com.gargoylesoftware.htmlunit.javascript.JavaScriptEngine) -
> > runtimeError: message=[ActiveXObject Error: no value for
> > Mxsml2.XMLHTTP.3.0.]
> > sourceName=[
> http://testserver/ScriptResource.axd?d=Q16yBbCVe2h9KDJ86qUi2PhkotP0xXinBhXErlIeswUtnsF9zzKwOPiAtJmYAW8WkuVZLCw-JJBEHZCTXaZtpOWTnuu6MG53FW83hLuNudY1&t=633414783035203188
> > <
> http://testserver/ScriptResource.axd?d=Q16yBbCVe2h9KDJ86qUi2PhkotP0xXinBhXErlIeswUtnsF9zzKwOPiAtJmYAW8WkuVZLCw-JJBEHZCTXaZtpOWTnuu6MG53FW83hLuNudY1&t=633414783035203188
> >]
> > line=[5] lineSource=[null] lineOffset=[0]
> >
> > My webtest is as follows:
> >
> > <webtest name="Create New Client" >
> >
> >                <invoke url="http://testserver"/>
> >             <verifyText text="Test Server System" />
> >             <setInputField name="ctl00$PageBody$TextBoxUserName"
> > value="test"/>
> >             <setInputField name="ctl00$PageBody$TextBoxPassword"
> > value="test1"/>
> >             <clickLink description="click link to log in" label="submit"
>  />
> >                 <verifyTitle description="Client Search must be present"
> > text="Client Search" />
> >
> >                 <!--======== Search for Client
> > =================================-->
> >                *<clickLink description="Go to Client Home" label="Test
> > Client"/>*
> >                <setInputField description="search for client"
> > name="ctl00$PageBody$textBoxClientSearch" value=Test Site"/>
> >                 <clickButton description="submit search"
> > name="ctl00$PageBody$buttonSearch" />
> >                 <verifyText description="Test server text must be
> > present" text="TEST_SERVER" />
> >
> > The link I am trying to click on is a javascript rgenerated link (Test
> > Client) and hence my problem.  I tried to use an xpath expression,
> > clickelement, and clicklink, with no success.  Any thoughts?
> >
> > - Steve C
> >
> > --
> > I'm not the person your mother warned you about... her imagination isn't
> > that good!
>
>
> _______________________________________________
> WebTest mailing list
> WebTest@lists.canoo.com
> http://lists.canoo.com/mailman/listinfo/webtest
>



-- 
I'm not the person your mother warned you about... her imagination isn't
that good!

------=_Part_45834_5972842.1219417557161
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

<div dir="ltr">Hi Marc,<br><br>Yes, this does work in IE.&nbsp; I checked the error console and this error does not come up in either ie or firefox.&nbsp; Mxsml2.XMLHTTP.3.0 only appears spelled that way in the webtest exception stack trace.&nbsp; Clicking on the link in both firefox and ie on windows/linux works hence my concern that this maybe an error in the manner in which I have written the test.&nbsp; The xpath to the link works with verfiyXpath and the correct values are passed into the javascript function.&nbsp; Is there anyway to disable activexerrors and continue with the test or do you have any other suggestions?<br>
<br>Thanks.<br><br><br><div class="gmail_quote">On Fri, Aug 22, 2008 at 2:55 AM, Marc Guillemot <span dir="ltr">&lt;<a href="mailto:mguillemot@yahoo.fr">mguillemot@yahoo.fr</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
Hi,<br>
<br>
are you sure that it works in your IE? &quot;Mxsml2.XMLHTTP.3.0&quot; is<br>
misspelled, it should be &quot;Msxml2.XMLHTTP.3.0&quot;: HtmlUnit able to catch<br>
errors with ActiveX! ;-)<br>
<br>
Cheers,<br>
Marc.<br>
--<br>
Blog: <a href="http://mguillem.wordpress.com" target="_blank">http://mguillem.wordpress.com</a><br>
<div><div></div><div class="Wj3C7c"><br>
<br>
Steve Chikwaya wrote:<br>
&gt; Hi all,<br>
&gt;<br>
&gt; I am getting the following error when trying to run a webtest on an<br>
&gt; internal site:<br>
&gt;<br>
&gt; [clickLink] ERROR<br>
&gt; (com.gargoylesoftware.htmlunit.javascript.JavaScriptEngine) -<br>
&gt; runtimeError: message=[ActiveXObject Error: no value for<br>
&gt; Mxsml2.XMLHTTP.3.0.]<br>
&gt; sourceName=[<a href="http://testserver/ScriptResource.axd?d=Q16yBbCVe2h9KDJ86qUi2PhkotP0xXinBhXErlIeswUtnsF9zzKwOPiAtJmYAW8WkuVZLCw-JJBEHZCTXaZtpOWTnuu6MG53FW83hLuNudY1&amp;t=633414783035203188" target="_blank">http://testserver/ScriptResource.axd?d=Q16yBbCVe2h9KDJ86qUi2PhkotP0xXinBhXErlIeswUtnsF9zzKwOPiAtJmYAW8WkuVZLCw-JJBEHZCTXaZtpOWTnuu6MG53FW83hLuNudY1&amp;t=633414783035203188</a><br>

&gt; &lt;<a href="http://testserver/ScriptResource.axd?d=Q16yBbCVe2h9KDJ86qUi2PhkotP0xXinBhXErlIeswUtnsF9zzKwOPiAtJmYAW8WkuVZLCw-JJBEHZCTXaZtpOWTnuu6MG53FW83hLuNudY1&amp;t=633414783035203188" target="_blank">http://testserver/ScriptResource.axd?d=Q16yBbCVe2h9KDJ86qUi2PhkotP0xXinBhXErlIeswUtnsF9zzKwOPiAtJmYAW8WkuVZLCw-JJBEHZCTXaZtpOWTnuu6MG53FW83hLuNudY1&amp;t=633414783035203188</a>&gt;]<br>

&gt; line=[5] lineSource=[null] lineOffset=[0]<br>
&gt;<br>
&gt; My webtest is as follows:<br>
&gt;<br>
&gt; &lt;webtest name=&quot;Create New Client&quot; &gt;<br>
&gt;<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;&lt;invoke url=&quot;<a href="http://testserver" target="_blank">http://testserver</a>&quot;/&gt;<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &lt;verifyText text=&quot;Test Server System&quot; /&gt;<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &lt;setInputField name=&quot;ctl00$PageBody$TextBoxUserName&quot;<br>
&gt; value=&quot;test&quot;/&gt;<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &lt;setInputField name=&quot;ctl00$PageBody$TextBoxPassword&quot;<br>
&gt; value=&quot;test1&quot;/&gt;<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &lt;clickLink description=&quot;click link to log in&quot; label=&quot;submit&quot; &nbsp;/&gt;<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &lt;verifyTitle description=&quot;Client Search must be present&quot;<br>
&gt; text=&quot;Client Search&quot; /&gt;<br>
&gt;<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &lt;!--======== Search for Client<br>
&gt; =================================--&gt;<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;*&lt;clickLink description=&quot;Go to Client Home&quot; label=&quot;Test<br>
&gt; Client&quot;/&gt;*<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;&lt;setInputField description=&quot;search for client&quot;<br>
&gt; name=&quot;ctl00$PageBody$textBoxClientSearch&quot; value=Test Site&quot;/&gt;<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &lt;clickButton description=&quot;submit search&quot;<br>
&gt; name=&quot;ctl00$PageBody$buttonSearch&quot; /&gt;<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &lt;verifyText description=&quot;Test server text must be<br>
&gt; present&quot; text=&quot;TEST_SERVER&quot; /&gt;<br>
&gt;<br>
&gt; The link I am trying to click on is a javascript rgenerated link (Test<br>
&gt; Client) and hence my problem. &nbsp;I tried to use an xpath expression,<br>
&gt; clickelement, and clicklink, with no success. &nbsp;Any thoughts?<br>
&gt;<br>
&gt; - Steve C<br>
&gt;<br>
&gt; --<br>
&gt; I&#39;m not the person your mother warned you about... her imagination isn&#39;t<br>
&gt; that good!<br>
<br>
<br>
</div></div>_______________________________________________<br>
WebTest mailing list<br>
<a href="mailto:WebTest@lists.canoo.com">WebTest@lists.canoo.com</a><br>
<a href="http://lists.canoo.com/mailman/listinfo/webtest" target="_blank">http://lists.canoo.com/mailman/listinfo/webtest</a><br>
</blockquote></div><br><br clear="all"><br>-- <br>I&#39;m not the person your mother warned you about... her imagination isn&#39;t that good!<br>
</div>

------=_Part_45834_5972842.1219417557161--