[Webtest] verifyXPath on /html/head/title returning 'parse' error in wt 2.6?

A Vander avander_be@yahoo.com
Mon, 8 Sep 2008 05:12:30 -0700 (PDT)


Hi guys,=20

I have several pages bombing out early due to what seems to be a rather gro=
ce parsing error in a verifyXPath step for the /html/head/title.=20

The error messages look like following excerpt:
--------------------------------------------------------------------------
BUILD FAILED
D:\tools\webtest-2.6\webtest.xml:184: The following error occurred while ex=
ecuti
ng this line:
D:\workspaceJP\jp-ep2i-tests-Canoo\src\main\web-test\usecases\allTests.xml:=
132:
The following error occurred while executing this line:
D:\workspaceJP\jp-ep2i-tests-Canoo\src\main\web-test\usecases\allTests.xml:=
141:
The following error occurred while executing this line:
D:\workspaceJP\jp-ep2i-tests-Canoo\src\main\web-test\usecases\login\loginDe=
AgeLo

wer18.xml:13: Wrong result for xpath >/html/head/title<. Expected value "Pr=
ofil
administratif/signal=CE=98tique - Conditions =CE=B1 l'inscription non rempl=
ies" but got "P
rofil administratif/signal=CE=98tique - Conditions =CE=B1 l'inscription non=
 remplies</titl
e> <meta http-equiv=3D"Cache-Control" content=3D"no-store" /> <meta http-eq=
uiv=3D"Prag
ma" content=3D"no-cache" /> <meta http-equiv=3D"Expires" content=3D"0" /> <=
meta http-e
quiv=3D"Content-Type" content=3D"text/html; charset=3DISO-8859-15" /> <link=
 rel=3D"style
sheet" href=3D"/jp-ep2i/styles/styleFxxxx.css" type=3D"text/css" media=3D"s=
creen"/> <s
cript language=3D"JavaScript" type=3D"text/javascript"> // Cette fonction p=
ermet de
v=CE=98rifier la validit=CE=98 d'une date au format jj/mm/aaaa function isD=
ate(d) { // Si
la variable est vide on retourne faux. if (d =3D=3D "") return true; // On =
teste l'e

... rest of the page here ...

 </body> </html>"

Total time: 4 seconds
--------------------------------------------------------------------------

It looks as if wt has his document tree mixed up and considers everything f=
ollowing the title's start tag as being part of the title. All pages presen=
ting this behaviour do validate using the FF HTML Validator extension.

Upgrading to latest build does solve the problem but breaks numerous verify=
XPath's that do work in wt 2.6. So it seems I'm stuck in a dead end street.=
..

Any ideas on how to avoid the 'parse error' or the xpath issue of the lates=
t build R_1716?=20

TIA, Avander




=0A=0A=0A