[Webtest] JS error on Google page: type(...) vs setAttributeValue(...) for setInputField

Søren Krum soren.krum@uninett.no
Thu, 11 Sep 2008 10:42:00 +0200

Ok, you asked, and after thinking a bit about it, here is my conclusion:

I would prefer to have both possibilities, even if that means that you have to enlarge your test cases, to handle all possibilities, but that is up to your own. 

A required extra parameter in setInputField would be technically cleanest, but lead to some trouble if you invent that, so politically i would understand to support backward compatibility. And then it should be the old way which is the default. But i like the idea of forcing the user to know what he is testing ;-)

I am not so deep in the code, may be it is possible to have it as a required parameter, if it is not specified in the config? but that would lead to a crowded config after a while. Positive would be that you can change your existing tests with one extra line in your hopefully separate config file to work with the new version, so it is a kind of painless.


Søren Krum