[Webtest] JavaScript error after loading xml page

Hitesh Gupta Hitesh Gupta" <hitesh21081@gmail.com
Wed, 24 Sep 2008 17:36:11 +0530


------=_Part_85868_7605066.1222257971285
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

Hi,

yeah you are right you need to use the patched version of this jar file i.e.
commons-httpclient-3.0.1-patched.jar file.

Cheers,
Hitesh

On Wed, Sep 24, 2008 at 5:31 PM, dariusch
<dariusch.zohurian@mindmatters.de>wrote:

>
> Hello,
>
> i use webtest 2.6. it includes commons-httpclient-3.1.jar. do you mean this
> one ?
>
> Cheers
> dariusch
>
>
> Hitesh Gupta wrote:
> >
> > Hi Marc,
> >
> > I got the same error while creating a script for one of the page. Then
> > after
> > a lot of search on internet I came to know that this error was due to
> some
> > CookieSpecBase class so I updated my commons-httpclient-3.0.1-patched.jar
> > file of the WebTest and then only I could resolve this error.
> >
> > Cheers,
> > Hitesh
> >
> > On Wed, Sep 24, 2008 at 4:57 PM, Marc Guillemot <mguillemot@yahoo.fr>
> > wrote:
> >
> >> Hi,
> >>
> >> are you simulating FF? If yes, this was a known bug in an older WebTest
> >> version. Please upgrade to the latest build
> >>
> >> @Hitesh
> >> what is commons-httpclient-3.0.1-patched.jar?
> >>
> >> Cheers,
> >> Marc.
> >> --
> >> Web: http://www.efficient-webtesting.com
> >> Blog: http://mguillem.wordpress.com
> >>
> >> dariusch wrote:
> >> > Hi,
> >> >
> >> > if i call <invoke url="http://localhost:8080/newsfeeds/atom_all.xml"
> />
> >> >
> >> > i get the following error messsage:
> >> >
> >> > JavaScript error loading page :
> >> com.gargoylesoftware.htmlunit.xml.XmlPage
> >> >
> >> > Some ideas ?
> >> >
> >> > Cheers,
> >> > dariusch
> >> >
> >> >
> >> >
> >>
> >> _______________________________________________
> >> WebTest mailing list
> >> WebTest@lists.canoo.com
> >> http://lists.canoo.com/mailman/listinfo/webtest
> >>
> >
> >
>
> --
> View this message in context:
> http://www.nabble.com/JavaScript-error-after-loading-xml-page-tp19646098p19647292.html
> Sent from the WebTest mailing list archive at Nabble.com.
>
> _______________________________________________
> WebTest mailing list
> WebTest@lists.canoo.com
> http://lists.canoo.com/mailman/listinfo/webtest
>

------=_Part_85868_7605066.1222257971285
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

<div dir="ltr">Hi,<br><br>yeah you are right you need to use the patched version of this jar file i.e. commons-httpclient-3.0.1-patched.jar file.<br><br>Cheers,<br>Hitesh<br><br><div class="gmail_quote">On Wed, Sep 24, 2008 at 5:31 PM, dariusch <span dir="ltr">&lt;<a href="mailto:dariusch.zohurian@mindmatters.de">dariusch.zohurian@mindmatters.de</a>&gt;</span> wrote:<br>
<blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;"><br>
Hello,<br>
<br>
i use webtest 2.6. it includes commons-httpclient-3.1.jar. do you mean this<br>
one ?<br>
<br>
Cheers<br>
dariusch<br>
<div><div></div><div class="Wj3C7c"><br>
<br>
Hitesh Gupta wrote:<br>
&gt;<br>
&gt; Hi Marc,<br>
&gt;<br>
&gt; I got the same error while creating a script for one of the page. Then<br>
&gt; after<br>
&gt; a lot of search on internet I came to know that this error was due to some<br>
&gt; CookieSpecBase class so I updated my commons-httpclient-3.0.1-patched.jar<br>
&gt; file of the WebTest and then only I could resolve this error.<br>
&gt;<br>
&gt; Cheers,<br>
&gt; Hitesh<br>
&gt;<br>
&gt; On Wed, Sep 24, 2008 at 4:57 PM, Marc Guillemot &lt;<a href="mailto:mguillemot@yahoo.fr">mguillemot@yahoo.fr</a>&gt;<br>
&gt; wrote:<br>
&gt;<br>
&gt;&gt; Hi,<br>
&gt;&gt;<br>
&gt;&gt; are you simulating FF? If yes, this was a known bug in an older WebTest<br>
&gt;&gt; version. Please upgrade to the latest build<br>
&gt;&gt;<br>
&gt;&gt; @Hitesh<br>
&gt;&gt; what is commons-httpclient-3.0.1-patched.jar?<br>
&gt;&gt;<br>
&gt;&gt; Cheers,<br>
&gt;&gt; Marc.<br>
&gt;&gt; --<br>
&gt;&gt; Web: <a href="http://www.efficient-webtesting.com" target="_blank">http://www.efficient-webtesting.com</a><br>
&gt;&gt; Blog: <a href="http://mguillem.wordpress.com" target="_blank">http://mguillem.wordpress.com</a><br>
&gt;&gt;<br>
&gt;&gt; dariusch wrote:<br>
&gt;&gt; &gt; Hi,<br>
&gt;&gt; &gt;<br>
&gt;&gt; &gt; if i call &lt;invoke url=&quot;<a href="http://localhost:8080/newsfeeds/atom_all.xml" target="_blank">http://localhost:8080/newsfeeds/atom_all.xml</a>&quot; /&gt;<br>
&gt;&gt; &gt;<br>
&gt;&gt; &gt; i get the following error messsage:<br>
&gt;&gt; &gt;<br>
&gt;&gt; &gt; JavaScript error loading page :<br>
&gt;&gt; com.gargoylesoftware.htmlunit.xml.XmlPage<br>
&gt;&gt; &gt;<br>
&gt;&gt; &gt; Some ideas ?<br>
&gt;&gt; &gt;<br>
&gt;&gt; &gt; Cheers,<br>
&gt;&gt; &gt; dariusch<br>
&gt;&gt; &gt;<br>
&gt;&gt; &gt;<br>
&gt;&gt; &gt;<br>
&gt;&gt;<br>
&gt;&gt; _______________________________________________<br>
&gt;&gt; WebTest mailing list<br>
&gt;&gt; <a href="mailto:WebTest@lists.canoo.com">WebTest@lists.canoo.com</a><br>
&gt;&gt; <a href="http://lists.canoo.com/mailman/listinfo/webtest" target="_blank">http://lists.canoo.com/mailman/listinfo/webtest</a><br>
&gt;&gt;<br>
&gt;<br>
&gt;<br>
<br>
</div></div><font color="#888888">--<br>
View this message in context: <a href="http://www.nabble.com/JavaScript-error-after-loading-xml-page-tp19646098p19647292.html" target="_blank">http://www.nabble.com/JavaScript-error-after-loading-xml-page-tp19646098p19647292.html</a><br>

</font><div class="Ih2E3d">Sent from the WebTest mailing list archive at Nabble.com.<br>
<br>
_______________________________________________<br>
</div><div><div></div><div class="Wj3C7c">WebTest mailing list<br>
<a href="mailto:WebTest@lists.canoo.com">WebTest@lists.canoo.com</a><br>
<a href="http://lists.canoo.com/mailman/listinfo/webtest" target="_blank">http://lists.canoo.com/mailman/listinfo/webtest</a><br>
</div></div></blockquote></div><br></div>

------=_Part_85868_7605066.1222257971285--