[Webtest] submit button is inactivated during the test

lostinheaven.lee@gmail.com lostinheaven.lee@gmail.com
Thu, 25 Sep 2008 16:23:50 +0800


------=_Part_39829_15836830.1222331030725
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

Hi,

   I'm testing an login page. Becouse of the JS error report, I made some
changes in the dtd folder,(refer to this mail:
http://www.nabble.com/%22Cannot-call-method-%22submit%22-of-undefined%22-Error-FIXED-td19549071.html).
I don't know the relation between the JS problem and the dtd file, but the
"undefined method"error didn't report any more.

   It comes another error, The submit button seems inactivated. when click
the submit button, it should goto another page. During the first step of the
2ed page,there comes the report "No current response available! Is previous
invoke missing?". then I canceled the test task on 2ed page, repeat the step
of click the submit button on login page for several times. no error
reported. It proves that the submit button can't invoke the next page. But
when you really click it,it could.

   what's the problem could be?  need opinions.

 many thanks !

Tracy

------=_Part_39829_15836830.1222331030725
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

<div dir="ltr"><div>Hi,</div>
<div>&nbsp;</div>
<div>&nbsp;&nbsp; I&#39;m testing an login page. Becouse of the JS error report, I made some changes in the dtd folder,(refer to this mail:<a href="http://www.nabble.com/%22Cannot-call-method-%22submit%22-of-undefined%22-Error-FIXED-td19549071.html" target="_blank">http://www.nabble.com/%22Cannot-call-method-%22submit%22-of-undefined%22-Error-FIXED-td19549071.html</a>). I don&#39;t know the relation between&nbsp;the JS problem and the dtd file, but the &quot;undefined method&quot;error didn&#39;t report any more.&nbsp;</div>

<div>&nbsp;</div>
<div>&nbsp;&nbsp; It comes another error, The submit button seems inactivated.&nbsp;when click the submit button,&nbsp;it should&nbsp;goto&nbsp;another&nbsp;page.&nbsp;During the first step of the 2ed page,there comes the report &quot;No current response available! Is previous invoke missing?&quot;. then I canceled the test task on 2ed page, repeat the step of click the submit button on login page for several times. no error reported. It proves that the submit button can&#39;t invoke the next page. But when you really click it,it could.</div>

<div>&nbsp;</div>
<div>&nbsp;&nbsp; what&#39;s the problem could be? &nbsp;need opinions.</div>
<div>&nbsp;</div>
<div>&nbsp;many thanks !</div>
<div>&nbsp;</div>
<div>Tracy</div>
<div>&nbsp;&nbsp; </div>
<div>&nbsp;&nbsp; </div></div>

------=_Part_39829_15836830.1222331030725--