[Webtest] Webtest upgrade to R_1810 (Akash Munjal)

Mato Mato <pichna@gmail.com>
Wed, 20 Apr 2011 14:20:18 +0200


On 11.2.2011 12:01, webtest-request@lists.canoo.com wrote:
> Webtest upgrade to R_1810 (Akash Munjal)
>
> Are there really performance improvements when we upgrade from
> Webtest R_1758 to R_1810?  In our case the upgrade seems to have
> deteriorated performance and also breaks a lot of the xpath values
> that worked in R_1758 and R_1766.
>
> Thanks,
>
> Akash.

Hi Akash,

Did you solve your problem? Because I have similar or probably the same
problems.
I tried version R_1811 and I see that all testplans needs more time for
running than it's on previous version. Some plans need twice and some
more than twice. And I see that the plan need less than 700MB of RAM on
version R_1766. But the same plan needs more than 1.3GB of RAM on
version R_1811.

And next problem some cases fails without real reason.
The interesting is that they aren't the same testcases for every run.
I tried the plans with easyajax  - set to on and off - but without
expected result in both cases. But the tested behavior works fine on the
real browsers (if the TC fails then I try the testcase do on real
browsers - IE8,IE7, IE6 !!! and FF2,FF3, FF3.6).

There are various problems when TC fails without real reason:
1.
When the user sets value for input and application needs to recalculate
another values (using the AJAX), the values are not recalculated. (I add
the sleeps for 5 seconds before set and after I set value).

2. When the user presses the button and the result of action should be
only update of information on page (using AJAX), the information are not
updated. The sleeps for 5 seconds (or more does not help). If the result
of button should be the opening of new page - it works fine.

3. When the invoke of new page should be done - it seems that it
often (but not always) fails without the sleep as previous and next
step. The invoke page displays error that something was not set (or was
set to NULL).


And the last problem on R_1811 the plan often finishes with message:
java.lang.IllegalStateException: No current result
But the main problem round this feature is that I can not open the
results which have been created until this problem, because the file
running.txt is missing.

example:
[echo] Formatting e:\..\results\..\WebTestReport.xml to HTML in folder
e:\..\results\..\
BUILD FAILED
C:\Canoo\webtest.xml:256: The following error occurred while executing
this line:
e:\Tests\testrunner.xml:6: The following error occurred while executing
this line:
e:\Tests\plans\myplan.xml:223: java.lang.IllegalStateException: No
current result


Can someone help me with these problems?
Thanks,
Mato