[Webtest] Re: Permgen, webtest, IntelliJ

Rob Rob <rob46@liveonthe.net>
Thu, 24 Nov 2011 15:16:21 +1000


This is a multi-part message in MIME format.
--------------090201040303020106030500
Content-Type: text/plain; charset=UTF-8; format=flowed
Content-Transfer-Encoding: 7bit

Peculiar.   It only dies on permgen when invoked at the command line 
when the url in the test is set to "/"
BTW, if I request the page from a browser / just redirects to /public 
and renders ok
Starting webtest from the command line, if I use invoke (url:'/public') 
in the test it completes ok and the tests pass, but if I use invoke 
(url:'/') or invoke "/" it dies on permgen.
That's at the command line.  IntelliJ is still having all sorts of 
trouble trying to run them, also still including throwing the permgen error.
Rob

On 24/11/2011 2:05 PM, Rob wrote:
> Sorry.  Trigger happy iPhone send button
>
> Continuing ... set the jvmargs maxpermsize. Now I've tried a few 
> permutations as recommended on various lists and official sites and 
> they all fail to effect a positive change.
>
> 1/ shouldn't this plugin work out if the box? What have I done wrong?
> 2/ can someone give me a tip as to where to set the maxpermsize for 
> either/both IntelliJ and command line invocation.
>
> Thanks in advance
> Rob M
>
> -----------------------
>
> On 24/11/2011, at 1:58 PM, Rob <rob46@liveonthe.net 
> <mailto:rob46@liveonthe.net>> wrote:
>
>> Hi.
>> I was on this list about 4 years ago, so greetings to some old timers
>> I just ran install-plugin webtest on an existing grails project under 
>> IntelliJ.
>> It didnt run up out of the box unfortunately and I've had to change a 
>> few settings to get it to run a one-trick test from the command line. 
>> It still doesn't run in IntelliJ.
>> The key problem I'm stuck on now is permgen.  In IntelliJ it gets 
>> halfway through and dies on permgen. At the command line it will run 
>> one test ok, but I've just added a second class with a single test 
>> and ... Permgen.
>> So I've read the searches and yes they all say to set the
>>
>> -----------------------


--------------090201040303020106030500
Content-Type: text/html; charset=UTF-8
Content-Transfer-Encoding: 8bit

<html>
  <head>
    <meta content="text/html; charset=UTF-8" http-equiv="Content-Type">
  </head>
  <body bgcolor="#FFFFFF" text="#000000">
    Peculiar.   It only dies on permgen when invoked at the command line
    when the url in the test is set to "/"<br>
    BTW, if I request the page from a browser / just redirects to
    /public and renders ok<br>
    Starting webtest from the command line, if I use invoke
    (url:'/public') in the test it completes ok and the tests pass, but
    if I use invoke (url:'/') or invoke "/" it dies on permgen.<br>
    That's at the command line.  IntelliJ is still having all sorts of
    trouble trying to run them, also still including throwing the
    permgen error.<br>
    Rob<br>
    <br>
    On 24/11/2011 2:05 PM, Rob wrote:
    <blockquote
      cite="mid:846C7799-2B02-49EE-916C-CB400D3FCC42@liveonthe.net"
      type="cite">
      <div><span class="Apple-style-span"
          style="-webkit-tap-highlight-color: rgba(26, 26, 26,
          0.296875); -webkit-composition-fill-color: rgba(175, 192, 227,
          0.230469); -webkit-composition-frame-color: rgba(77, 128, 180,
          0.230469); font-size: medium; "><span>Sorry.  Trigger happy
            iPhone send button</span></span><span
          class="Apple-style-span" style="-webkit-tap-highlight-color:
          rgba(26, 26, 26, 0.296875); -webkit-composition-fill-color:
          rgba(175, 192, 227, 0.230469);
          -webkit-composition-frame-color: rgba(77, 128, 180, 0.230469);
          font-size: medium; "><br>
        </span><span class="Apple-style-span"
          style="-webkit-tap-highlight-color: rgba(26, 26, 26,
          0.296875); -webkit-composition-fill-color: rgba(175, 192, 227,
          0.230469); -webkit-composition-frame-color: rgba(77, 128, 180,
          0.230469); font-size: medium; "><span></span></span><span
          class="Apple-style-span" style="-webkit-tap-highlight-color:
          rgba(26, 26, 26, 0.296875); -webkit-composition-fill-color:
          rgba(175, 192, 227, 0.230469);
          -webkit-composition-frame-color: rgba(77, 128, 180, 0.230469);
          font-size: medium; "><br>
        </span><span class="Apple-style-span"
          style="-webkit-tap-highlight-color: rgba(26, 26, 26,
          0.296875); -webkit-composition-fill-color: rgba(175, 192, 227,
          0.230469); -webkit-composition-frame-color: rgba(77, 128, 180,
          0.230469); font-size: medium; "><span>Continuing ... set the
            jvmargs maxpermsize. Now I've tried a few permutations as
            recommended on various lists and official sites and they all
            fail to effect a positive change. </span></span><span
          class="Apple-style-span" style="-webkit-tap-highlight-color:
          rgba(26, 26, 26, 0.296875); -webkit-composition-fill-color:
          rgba(175, 192, 227, 0.230469);
          -webkit-composition-frame-color: rgba(77, 128, 180, 0.230469);
          font-size: medium; "><br>
        </span><span class="Apple-style-span"
          style="-webkit-tap-highlight-color: rgba(26, 26, 26,
          0.296875); -webkit-composition-fill-color: rgba(175, 192, 227,
          0.230469); -webkit-composition-frame-color: rgba(77, 128, 180,
          0.230469); font-size: medium; "><span></span></span><span
          class="Apple-style-span" style="-webkit-tap-highlight-color:
          rgba(26, 26, 26, 0.296875); -webkit-composition-fill-color:
          rgba(175, 192, 227, 0.230469);
          -webkit-composition-frame-color: rgba(77, 128, 180, 0.230469);
          font-size: medium; "><br>
        </span><span class="Apple-style-span"
          style="-webkit-tap-highlight-color: rgba(26, 26, 26,
          0.296875); -webkit-composition-fill-color: rgba(175, 192, 227,
          0.230469); -webkit-composition-frame-color: rgba(77, 128, 180,
          0.230469); font-size: medium; "><span>1/ shouldn't this plugin
            work out if the box? What have I done wrong?</span></span><span
          class="Apple-style-span" style="-webkit-tap-highlight-color:
          rgba(26, 26, 26, 0.296875); -webkit-composition-fill-color:
          rgba(175, 192, 227, 0.230469);
          -webkit-composition-frame-color: rgba(77, 128, 180, 0.230469);
          font-size: medium; "><br>
        </span><span class="Apple-style-span"
          style="-webkit-tap-highlight-color: rgba(26, 26, 26,
          0.296875); -webkit-composition-fill-color: rgba(175, 192, 227,
          0.230469); -webkit-composition-frame-color: rgba(77, 128, 180,
          0.230469); font-size: medium; "><span>2/ can someone give me a
            tip as to where to set the maxpermsize for either/both
            IntelliJ and command line invocation. </span></span><span
          class="Apple-style-span" style="-webkit-tap-highlight-color:
          rgba(26, 26, 26, 0.296875); -webkit-composition-fill-color:
          rgba(175, 192, 227, 0.230469);
          -webkit-composition-frame-color: rgba(77, 128, 180, 0.230469);
          font-size: medium; "><br>
        </span><span class="Apple-style-span"
          style="-webkit-tap-highlight-color: rgba(26, 26, 26,
          0.296875); -webkit-composition-fill-color: rgba(175, 192, 227,
          0.230469); -webkit-composition-frame-color: rgba(77, 128, 180,
          0.230469); font-size: medium; "><span></span></span><span
          class="Apple-style-span" style="-webkit-tap-highlight-color:
          rgba(26, 26, 26, 0.296875); -webkit-composition-fill-color:
          rgba(175, 192, 227, 0.230469);
          -webkit-composition-frame-color: rgba(77, 128, 180, 0.230469);
          font-size: medium; "><br>
        </span><span class="Apple-style-span"
          style="-webkit-tap-highlight-color: rgba(26, 26, 26,
          0.296875); -webkit-composition-fill-color: rgba(175, 192, 227,
          0.230469); -webkit-composition-frame-color: rgba(77, 128, 180,
          0.230469); font-size: medium; "><span>Thanks in advance </span></span><span
          class="Apple-style-span" style="-webkit-tap-highlight-color:
          rgba(26, 26, 26, 0.296875); -webkit-composition-fill-color:
          rgba(175, 192, 227, 0.230469);
          -webkit-composition-frame-color: rgba(77, 128, 180, 0.230469);
          font-size: medium; "><br>
        </span><span class="Apple-style-span"
          style="-webkit-tap-highlight-color: rgba(26, 26, 26,
          0.296875); -webkit-composition-fill-color: rgba(175, 192, 227,
          0.230469); -webkit-composition-frame-color: rgba(77, 128, 180,
          0.230469); font-size: medium; "><span>Rob M</span></span><br>
        <br>
        -----------------------</div>
      <div><br>
        On 24/11/2011, at 1:58 PM, Rob &lt;<a moz-do-not-send="true"
          href="mailto:rob46@liveonthe.net">rob46@liveonthe.net</a>&gt;
        wrote:<br>
        <br>
      </div>
      <blockquote type="cite">
        <div><span>Hi. </span><br>
          <span>I was on this list about 4 years ago, so greetings to
            some old timers</span><br>
          <span>I just ran install-plugin webtest on an existing grails
            project under IntelliJ. </span><br>
          <span>It didnt run up out of the box unfortunately and I've
            had to change a few settings to get it to run a one-trick
            test from the command line. It still doesn't run in
            IntelliJ. </span><br>
          <span>The key problem I'm stuck on now is permgen.  In
            IntelliJ it gets halfway through and dies on permgen. At the
            command line it will run one test ok, but I've just added a
            second class with a single test and ... Permgen. </span><br>
          <span>So I've read the searches and yes they all say to set
            the </span><br>
          <span></span><br>
          <span>-----------------------</span></div>
      </blockquote>
    </blockquote>
    <br>
  </body>
</html>

--------------090201040303020106030500--