[Webtest] Re: random running order

Josep García Josep García
Thu, 23 Feb 2012 12:11:16 +0100


--e89a8fb20272f0076704b99fb36c
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

I think my problem is related to using the group task.
When using group, tests seem to run in random order, on my linux box. Not
on windows, though. Strange.

Example:
<target name"test1">
   <webtest name=3D"test1">
       <group description=3D"1-1">
            <invoke ...>
            <clickLink ...>
           ....
       </group>
       <group description=3D"1-2">
         ....
       </group>
    </webtest>
  </target>

Any reason for that behaviour when using group?

Thanks,
Josep


2012/2/22 Josep Garc=C3=ADa <jgarcia@isigma.es>

> Hey,
>
> I am having a random running order of my webtests executed in Jenkins. I
> recall some comment related to this. Could it be related to the ant libra=
ry
> version used?
> I am actually running webtests via the webtest-maven-plugin.
>
> Cheers,
> Josep
>
>

--e89a8fb20272f0076704b99fb36c
Content-Type: text/html; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

I think my problem is related to using the group task.<br>When using group,=
 tests seem to run in random order, on my linux box. Not on windows, though=
. Strange.<br><br>Example:<br>&lt;target name&quot;test1&quot;&gt;<br>=C2=
=A0=C2=A0 &lt;webtest name=3D&quot;test1&quot;&gt;<br>
=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 &lt;group description=3D&quot;1-1&quot=
;&gt;<br>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=
 &lt;invoke ...&gt;<br>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=
=A0=C2=A0=C2=A0 &lt;clickLink ...&gt;<br>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=
=A0=C2=A0=C2=A0=C2=A0=C2=A0 ....<br>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 &l=
t;/group&gt;<br>
=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 &lt;group description=3D&quot;1-2&quot=
;&gt;<br>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 ....<br>
=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 &lt;/group&gt;<br>

=C2=A0=C2=A0=C2=A0 &lt;/webtest&gt;<br>=C2=A0

&lt;/target&gt;<br><br>Any reason for that behaviour when using group?<br><=
br>Thanks,<br>Josep<br><br><br><div class=3D"gmail_quote">2012/2/22 Josep G=
arc=C3=ADa <span dir=3D"ltr">&lt;<a href=3D"mailto:jgarcia@isigma.es">jgarc=
ia@isigma.es</a>&gt;</span><br>
<blockquote class=3D"gmail_quote" style=3D"margin:0 0 0 .8ex;border-left:1p=
x #ccc solid;padding-left:1ex">Hey,<br><br>I am having a random running ord=
er of my webtests executed in Jenkins. I recall some comment related to thi=
s. Could it be related to the ant library version used?<br>
I am actually running webtests via the webtest-maven-plugin.<br>
<br>Cheers,<br>Josep<br><br>
</blockquote></div><br>

--e89a8fb20272f0076704b99fb36c--