[Webtest] Is IE8 supported by Canoo Webtest: R_1812?

Elizabeth Nguyen Elizabeth Nguyen <enguyen@transydian.com>
Mon, 27 Feb 2012 00:24:22 -0700


--047d7b33d4c2deb82004b9ecffcb
Content-Type: text/plain; charset=ISO-8859-1

Hello everyone, I'm trying to use the installTest.xml that was provided
with the WebTest build R_1812 and needed to change the browser to the
version I have installed (this is on a W7 box if that matters).

In the installTest.xml, I have these configs defined:
            <config
                host="vmware4-2"
                port="8080"
                basepath="/"
browser="IE8"
                haltonfailure="true"
                protocol="http"/>

But in running the test, I get this error(java.lang.NoSuchFieldError:
INTERNET_EXPLORER_8).  I also tried specifying the value as
InternetExplorer8 per the canoo website but got the same error.  I realize
this is really htmlunit running underneath but wonder why it's not working?

Thanks in advance.

c:\Webtest\myWebTestProject\tests>webtest -f installtest.xml
"C:\Program Files\Java\jdk1.6.0_26\bin\java.exe" -Xms64M -Xmx256M -cp
"C:\Users\enguyen\WebTest\bin\..\lib\ant-launcher-
1.7.0.jar" -Dant.library.dir="C:\Users\enguyen\WebTest\bin\..\lib"
"-Dlog4j.configuration=file:/C:\Users\enguyen\WebTest
\bin\..\lib/log4j.properties" org.apache.tools.ant.launch.Launcher
-nouserlib -lib "C:\Users\enguyen\WebTest\bin\..\lib\
build;C:\Users\enguyen\WebTest\bin\..\lib\build\clover.jar" -f
installtest.xml
Buildfile: installtest.xml

checkANT:

mayPrintANTError:

wt.init:

wt.defineTasks.init:

~wt.defineTasks.defineClasspath:

wt.defineTasks:

checkWebTest:
     [echo] webtest.home is c:\Webtest\myWebTestProject\tests\..\..
  [webtest]  INFO (com.canoo.webtest.ant.WebtestTask) - Starting webtest
"check calling and parsing a local file" (c:\We
btest\myWebTestProject\tests\installtest.xml:10: )
  [webtest]  INFO (com.canoo.webtest.ant.WebtestTask) - Canoo Webtest:
R_1812.
   [config]  INFO (com.canoo.webtest.engine.Configuration) - Using
haltonerror from project property wt.config.haltonerr
or: false
   [config]  INFO (com.canoo.webtest.engine.Configuration) - Using
resultpath from project property wt.config.resultpath
: c:\Webtest\myWebTestProject\tests\results
   [config]  INFO (com.canoo.webtest.engine.Configuration) - Using
saveresponse from project property wt.config.saveresp
onse: true
   [config]  INFO (com.canoo.webtest.engine.Configuration) - Creating
result directory: c:\Webtest\myWebTestProject\test
s\results\013_CheckCallingAndParsingALocalFile

BUILD FAILED
c:\Webtest\myWebTestProject\tests\installtest.xml:17:
java.lang.NoSuchFieldError: INTERNET_EXPLORER_8

Total time: 1 second

--047d7b33d4c2deb82004b9ecffcb
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

Hello everyone, I&#39;m trying to use the installTest.xml that was provided=
 with the WebTest build R_1812 and needed to change the browser to the vers=
ion I have installed (this is on a W7 box if that matters).<div><br></div>
<div>In the installTest.xml, I have these configs defined:</div><div><div>=
=A0<font color=3D"#3333ff"> =A0 =A0 =A0 =A0 =A0 &lt;config</font></div><div=
><font color=3D"#3333ff">=A0 =A0 =A0 =A0 =A0 =A0 =A0 =A0 host=3D&quot;vmwar=
e4-2&quot;</font></div><div><font color=3D"#3333ff">=A0 =A0 =A0 =A0 =A0 =A0=
 =A0 =A0 port=3D&quot;8080&quot;</font></div>
<div><font color=3D"#3333ff">=A0 =A0 =A0 =A0 =A0 =A0 =A0 =A0 basepath=3D&qu=
ot;/&quot;</font></div><div><font color=3D"#3333ff"><span class=3D"Apple-ta=
b-span" style=3D"white-space:pre">		</span>browser=3D&quot;IE8&quot;</font>=
</div><div><font color=3D"#3333ff">=A0 =A0 =A0 =A0 =A0 =A0 =A0 =A0 haltonfa=
ilure=3D&quot;true&quot;</font></div>
<div><font color=3D"#3333ff">=A0 =A0 =A0 =A0 =A0 =A0 =A0 =A0 protocol=3D&qu=
ot;http&quot;/&gt;</font></div><div><br></div><div>But in running the test,=
 I get this error(<span style=3D"color:rgb(255,0,0)">java.lang.NoSuchFieldE=
rror: INTERNET_EXPLORER_8). =A0</span>I also tried specifying the value as =
InternetExplorer8 per the canoo website but got the same error. =A0I realiz=
e this is really htmlunit running underneath but wonder why it&#39;s not wo=
rking?</div>
<div><br></div><div>Thanks in advance.</div><div><span style=3D"color:rgb(2=
55,0,0)"><br></span></div><div><div>c:\Webtest\myWebTestProject\tests&gt;we=
btest -f installtest.xml</div><div>&quot;C:\Program Files\Java\jdk1.6.0_26\=
bin\java.exe&quot; -Xms64M -Xmx256M -cp &quot;C:\Users\enguyen\WebTest\bin\=
..\lib\ant-launcher-</div>
<div>1.7.0.jar&quot; -Dant.library.dir=3D&quot;C:\Users\enguyen\WebTest\bin=
\..\lib&quot; &quot;-Dlog4j.configuration=3Dfile:/C:\Users\enguyen\WebTest<=
/div><div>\bin\..\lib/log4j.properties&quot; org.apache.tools.ant.launch.La=
uncher -nouserlib -lib &quot;C:\Users\enguyen\WebTest\bin\..\lib\</div>
<div>build;C:\Users\enguyen\WebTest\bin\..\lib\build\clover.jar&quot; -f in=
stalltest.xml</div><div>Buildfile: installtest.xml</div><div><br></div><div=
>checkANT:</div><div><br></div><div>mayPrintANTError:</div><div><br></div>
<div>wt.init:</div><div><br></div><div>wt.defineTasks.init:</div><div><br><=
/div><div>~wt.defineTasks.defineClasspath:</div><div><br></div><div>wt.defi=
neTasks:</div><div><br></div><div>checkWebTest:</div><div>=A0 =A0 =A0[echo]=
 webtest.home is c:\Webtest\myWebTestProject\tests\..\..</div>
<div>=A0 [webtest] =A0INFO (com.canoo.webtest.ant.WebtestTask) - Starting w=
ebtest &quot;check calling and parsing a local file&quot; (c:\We</div><div>=
btest\myWebTestProject\tests\installtest.xml:10: )</div><div>=A0 [webtest] =
=A0INFO (com.canoo.webtest.ant.WebtestTask) - Canoo Webtest: R_1812.</div>
<div>=A0 =A0[config] =A0INFO (com.canoo.webtest.engine.Configuration) - Usi=
ng haltonerror from project property wt.config.haltonerr</div><div>or: fals=
e</div><div>=A0 =A0[config] =A0INFO (com.canoo.webtest.engine.Configuration=
) - Using resultpath from project property wt.config.resultpath</div>
<div>: c:\Webtest\myWebTestProject\tests\results</div><div>=A0 =A0[config] =
=A0INFO (com.canoo.webtest.engine.Configuration) - Using saveresponse from =
project property wt.config.saveresp</div><div>onse: true</div><div>=A0 =A0[=
config] =A0INFO (com.canoo.webtest.engine.Configuration) - Creating result =
directory: c:\Webtest\myWebTestProject\test</div>
<div>s\results\013_CheckCallingAndParsingALocalFile</div><div><br></div><di=
v><font color=3D"#ff0000">BUILD FAILED</font></div><div><font color=3D"#ff0=
000">c:\Webtest\myWebTestProject\tests\installtest.xml:17: java.lang.NoSuch=
FieldError: INTERNET_EXPLORER_8</font></div>
<div><br></div><div>Total time: 1 second</div></div></div>

--047d7b33d4c2deb82004b9ecffcb--